Bug 1652843 - python3 FTBFS on rawhide (test_email failure related to time.mktime OverflowError)
Summary: python3 FTBFS on rawhide (test_email failure related to time.mktime OverflowE...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1653340
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 09:15 UTC by Miro Hrončok
Modified: 2018-11-28 16:42 UTC (History)
11 users (show)

Fixed In Version: python3-3.7.1-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-28 16:42:19 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Python 35317 None None None 2018-11-26 14:56:27 UTC

Description Miro Hrončok 2018-11-23 09:15:12 UTC
Since https://apps.fedoraproject.org/koschei/build/5678942 the python3 package is FTBFS in Koji with:



======================================================================
ERROR: test_localtime_daylight_false_dst_true (test.test_email.test_utils.LocaltimeTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-3.7.1/Lib/test/test_email/test_utils.py", line 88, in test_localtime_daylight_false_dst_true
    t1 = utils.localtime(t0, isdst=1)
  File "/builddir/build/BUILD/Python-3.7.1/Lib/email/utils.py", line 361, in localtime
    seconds = time.mktime(tm)
OverflowError: mktime argument out of range
======================================================================
ERROR: test_localtime_daylight_true_dst_true (test.test_email.test_utils.LocaltimeTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-3.7.1/Lib/test/test_email/test_utils.py", line 81, in test_localtime_daylight_true_dst_true
    t1 = utils.localtime(t0, isdst=1)
  File "/builddir/build/BUILD/Python-3.7.1/Lib/email/utils.py", line 361, in localtime
    seconds = time.mktime(tm)
OverflowError: mktime argument out of range
----------------------------------------------------------------------



Updated packages:

 systemtap   4.0-2.fc30          4.0-3.fc30

 glibc       2.28.9000-16.fc30   2.28.9000-17.fc30

 elfutils    0.174-5.fc30        0.175-1.fc30

 pam         1.3.1-7.fc30        1.3.1-8.fc30



I was not yet able to reproduce this in mock. (I have the "new" package versions, so this is not a mirror sync thing.)

Since the test does with DST, I tough maybe the change of DST in USA is to blame, but the failure started weeks later, ale the DST detection is mocked.

Comment 1 Victor Stinner 2018-11-26 13:40:07 UTC
It would help to have the output of "python3 -m test.pythoninfo" which contains debug information. For example, you get info like:

time.altzone: -7200
time.timezone: -3600
time.tzname: ('EET', 'EET')

Comment 4 Miro Hrončok 2018-11-28 16:42:19 UTC
Thanks Victor.


Note You need to log in before you can comment on or make changes to this bug.