Bug 1652859 - rhnreg_ks no longer works with --proxy parameter
Summary: rhnreg_ks no longer works with --proxy parameter
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rhn-client-tools
Version: 8.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Michael Mráka
QA Contact: Jan Hutař
URL:
Whiteboard:
: 1656646 (view as bug list)
Depends On:
Blocks: 1647562
TreeView+ depends on / blocked
 
Reported: 2018-11-23 10:31 UTC by vinzenz.meier
Modified: 2019-06-11 19:44 UTC (History)
4 users (show)

Fixed In Version: rhnlib-2.8.6-6-el8 satellite-5-client-1.0-820181219103855.9edba152
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-21 11:41:24 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description vinzenz.meier 2018-11-23 10:31:40 UTC
Description of problem:
when using rhnreg_ks with "--proxy=" option, it fails 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
[root@vimappss-vrhel7 ~]# rhnreg_ks --serverUrl=https://linux-mgmt.itoper.local/XMLRPC --sslCACert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT --activationkey=2-bfe6618f6b7348f605b8ed80116bbc74,2-af481ade4e5e8817104a49bae1d0bf9a --proxy=http://10.174.96.50:8080 --profilename=vimappss-vrhel7.it.bwns.ch
An error has occurred:
<class 'AttributeError'>
See /var/log/up2date for more information


Actual results:
[root@vimappss-vrhel7 ~]# cat /var/log/up2date 
[Fri Nov 23 11:12:38 2018] up2date 
Traceback (most recent call last):
  File "/sbin/rhnreg_ks", line 215, in <module>
    cli.run()
  File "/usr/lib/python3.6/site-packages/up2date_client/rhncli.py", line 94, in run
    sys.exit(self.main() or 0)
  File "/sbin/rhnreg_ks", line 93, in main
    rhnreg.getCaps()
  File "/usr/lib/python3.6/site-packages/up2date_client/rhnreg.py", line 264, in getCaps
    s.capabilities.validate()
  File "/usr/lib/python3.6/site-packages/up2date_client/rhnserver.py", line 67, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/up2date_client/rpcServer.py", line 214, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib64/python3.6/xmlrpc/client.py", line 1112, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python3.6/site-packages/up2date_client/rpcServer.py", line 48, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python3.6/site-packages/rhn/rpclib.py", line 394, in _request
    self._handler, request, verbose=self._verbose)
  File "/usr/lib/python3.6/site-packages/rhn/transports.py", line 153, in request
    connection = self.get_connection(host)
  File "/usr/lib/python3.6/site-packages/rhn/transports.py", line 333, in get_connection
    trusted_certs=self.trusted_certs)
  File "/usr/lib/python3.6/site-packages/rhn/connections.py", line 210, in __init__
    password, timeout=timeout)
  File "/usr/lib/python3.6/site-packages/rhn/connections.py", line 128, in __init__
    self._set_hostport(host, port)
<class 'AttributeError'>: 'HTTPSProxyConnection' object has no attribute '_set_hostport'



Expected results:


Additional info:
[root@vimappss-vrhel7 ~]# rpm -qa |egrep 'rhn|spacew'
python3-rhn-check-2.8.16-11.module+el8+2180+4b61dcd8.x86_64
rhn-setup-2.8.16-11.module+el8+2180+4b61dcd8.x86_64
rhn-client-tools-2.8.16-11.module+el8+2180+4b61dcd8.x86_64
dnf-plugin-spacewalk-2.8.5-7.module+el8+2180+4b61dcd8.noarch
rhn-check-2.8.16-11.module+el8+2180+4b61dcd8.x86_64
python3-rhn-setup-2.8.16-11.module+el8+2180+4b61dcd8.x86_64
rhnlib-2.8.6-5.module+el8+2180+4b61dcd8.noarch
python3-rhnlib-2.8.6-5.module+el8+2180+4b61dcd8.noarch
python3-rhn-client-tools-2.8.16-11.module+el8+2180+4b61dcd8.x86_64
python3-dnf-plugin-spacewalk-2.8.5-7.module+el8+2180+4b61dcd8.noarch
rhnsd-5.0.35-3.module+el8+2180+4b61dcd8.x86_64


Spacewalk Server is latest 2.8 running on rhel7

Comment 1 vinzenz.meier 2018-11-23 10:35:02 UTC
Probably related:
https://bugzilla.redhat.com/show_bug.cgi?id=1546351

Comment 2 Tomas Lestach 2018-11-26 16:23:31 UTC
I'm afraid this BZ isn't properly reported.

Vinzenz, if you discover any issue, please open a case with Red Hat Support.

Comment 5 vinzenz.meier 2018-11-29 12:44:49 UTC
Tomas, Red Hat will probably not accept the case because of the use of the unsupported upstream Spacewalk. 
Eventually this error will come up on centos8 / upstream rhnlib
But if you can state that this is clearly a rhel8-beta error, I will open a case

Comment 10 Michael Mráka 2018-12-18 14:44:38 UTC
*** Bug 1656646 has been marked as a duplicate of this bug. ***

Comment 11 Michael Mráka 2018-12-18 14:51:04 UTC
Fixed in spacewalk git by
commit 9a6371bb7f7d37873ce197be193aa7df33f8385f
    1652859 - python3 http.client does not contain _set_hostport()

Comment 15 Michael Mráka 2019-05-21 11:41:24 UTC
The bug has been addresses and released as a part of Red Hat Enterprise Linux 8 GA.


Note You need to log in before you can comment on or make changes to this bug.