Bug 1652865 - intel I219-LM rev 10 (e1000e driver) packet loss on HP ProDesk 600 G4 DM
Summary: intel I219-LM rev 10 (e1000e driver) packet loss on HP ProDesk 600 G4 DM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 10:52 UTC by Ingvar Hagelund
Modified: 2019-01-30 15:16 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-30 15:16:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Ingvar Hagelund 2018-11-23 10:52:04 UTC
Description of problem:
HP ProDesk 600 G4 DM has packet loss over ethernet (wifi works fine)

Version-Release number of selected component (if applicable):
kernel-4.19.2-301.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Get hold of a HP ProDesk 600 G4. Install latest firmware.
2. Connect onboard ethernet to a live outlet. Get an IP address.
3. ping -c20 google.com

Actual results:
10-50% package loss

Expected results:
0% package loss

Workaroud: Use Wifi or a USB-to-ethernet dongle

Additional info:
This bug was observed on three similar workstations over the last months. Interestingly, a fourth workstation that did not update to latest firmware, is not able to trig the bug. The latest firmware from HP has an update for the network interface firmware, so this may be important.

I have also tested the latest driver from Intel*, that is e1000e-3.4.2.1. It has the same problem.

buggy_workstation$ sudo dmidecode | grep -A26 'BIOS Information'
BIOS Information
	Vendor: HP
	Version: Q22 Ver. 02.02.04
	Release Date: 08/06/2018
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 32 MB
	Characteristics:
		PCI is supported
		PC Card (PCMCIA) is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		EDD is supported
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Function key-initiated network boot is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 2.4
	Firmware Revision: 7.180

workstation_without_the_bug$ sudo dmidecode | grep -A26 'BIOS Information'
BIOS Information
	Vendor: HP
	Version: Q22 Ver. 02.01.06
	Release Date: 05/12/2018
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 32 MB
	Characteristics:
		PCI is supported
		PC Card (PCMCIA) is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		EDD is supported
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Function key-initiated network boot is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 1.6
	Firmware Revision: 7.152


buggy_workstation$ sudo lspci -vvv | grep -A14 'Ethernet controller'
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-LM (rev 10)
	DeviceName: Onboard Lan
	Subsystem: Hewlett-Packard Company Device 83ef
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 125
	Region 0: Memory at f0100000 (32-bit, non-prefetchable) [size=128K]
	Capabilities: [c8] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=1 PME-
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
		Address: 00000000fee00298  Data: 0000
	Kernel driver in use: e1000e
	Kernel modules: e1000e

buggy_workstation$ modinfo e1000e | head -6
filename:       /lib/modules/4.19.2-301.fc29.x86_64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko.xz
version:        3.2.6-k
license:        GPL
description:    Intel(R) PRO/1000 Network Driver
author:         Intel Corporation, <linux.nics@intel.com>
srcversion:     E5F1BBB6319ACF9CF582C86





*) Latest Intel driver for e1000e found here: https://downloadcenter.intel.com/download/22283/Ethernet-Intel-Ethernet-Adapter-Complete-Driver-Pack?product=82185

Comment 1 Ingvar Hagelund 2018-11-23 10:58:19 UTC
More hardware model details:

buggy_workstation$ sudo dmidecode | grep -A8 'System Information'
System Information
	Manufacturer: HP
	Product Name: HP ProDesk 600 G4 DM
	Version:  
	Serial Number: [removed from paste]
	UUID: [removed from paste]
	Wake-up Type: Power Switch
	SKU Number: 4KV72EA#UUW
	Family: 103C_53307F HP ProDesk

buggy_workstation$ sudo dmidecode | grep -A3 'Base Board Information'
Base Board Information
	Manufacturer: HP
	Product Name: 83EF
	Version: KBC Version 07.B4.00

Comment 2 Justin M. Forbes 2019-01-29 16:13:28 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 4.20.5-200.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 3 Ingvar Hagelund 2019-01-30 15:14:26 UTC
This bug seems fixed with the latest kernel and linux-firmware. Unsure which of those components that actually fixed it. The system BIOS/firmware package from HP is unchanged.

I guess you may close this bug as ERRATA on the release of kernel-4.20.5-200.fc29 .

Ingvar



$ rpm -q linux-firmware
linux-firmware-20190118-91.gita8b75cac.fc29.noarch

$ uname -r
4.20.5-200.fc29.x86_64

$ ethtool -i eno1 
driver: e1000e
version: 3.2.6-k
firmware-version: 0.5-4
expansion-rom-version: 
bus-info: 0000:00:1f.6
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no

$ sudo dmidecode | grep -A1 'BIOS Revision'
	BIOS Revision: 2.4
	Firmware Revision: 7.180

Comment 4 Justin M. Forbes 2019-01-30 15:16:00 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.