Bug 1652903 - Minor Upgrade deployment stuck and fails
Summary: Minor Upgrade deployment stuck and fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-apply-config
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: async
: 10.0 (Newton)
Assignee: Steve Baker
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On: 1653513
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 13:15 UTC by PURANDHAR SAIRAM MANNIDI
Modified: 2019-01-16 17:16 UTC (History)
8 users (show)

Fixed In Version: os-apply-config-5.1.1-3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 17:09:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0075 None None None 2019-01-16 17:09:10 UTC

Description PURANDHAR SAIRAM MANNIDI 2018-11-23 13:15:34 UTC
Description of problem:
Minor Upgrade deployment stuck and fails

Version-Release number of selected component (if applicable):
Red Hat OpenStack Platform 10

How reproducible:
Always

Steps to Reproduce:
1. Openstack minor upgrade fails timing out at Post Deployment
2. Subsequent deployment is stuck in IN_PROGRESS but the deployment-show command shows status_code:0 and has deploy_stdout 
3.

Actual results:
Deployment is stuck

Expected results:
Deployment should proceed and complete

Additional info:

Comment 20 Steve Baker 2018-11-27 03:01:06 UTC
I'll start backporting this fix to releases back as far as OSP-10: https://review.openstack.org/#/c/506328/

Comment 21 Steve Baker 2018-11-27 03:22:29 UTC
Bug #1653513 is to track the backport and hotfix release of the change https://code.engineering.redhat.com/gerrit/#/c/156888/

Comment 26 Carlos Camacho 2018-12-03 11:15:41 UTC
os-apply-config hot fix provided.

Comment 35 errata-xmlrpc 2019-01-16 17:09:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0075


Note You need to log in before you can comment on or make changes to this bug.