Bug 1652989 - Overcloud deployment fails when containers images are pulled from remote satellite(not from undercloud)
Summary: Overcloud deployment fails when containers images are pulled from remote sate...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: rc
: 14.0 (Rocky)
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1653462
TreeView+ depends on / blocked
 
Reported: 2018-11-23 21:04 UTC by Marius Cornea
Modified: 2019-01-11 11:55 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-common-9.4.1-0.20181012010880.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1653462 (view as bug list)
Environment:
Last Closed: 2019-01-11 11:55:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/lib/mistral/overcloud (2.19 MB, application/x-gzip)
2018-11-23 21:09 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1805184 None None None 2018-11-26 17:08:49 UTC
OpenStack gerrit 620117 None None None 2018-11-26 18:13:05 UTC
OpenStack gerrit 620172 None None None 2018-11-26 22:18:52 UTC
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:55:11 UTC

Description Marius Cornea 2018-11-23 21:04:56 UTC
Description of problem:
Overcloud deployment fails when containers images are pulled from remote satellite(not from undercloud). 

The overcloud nodes do not get INSECURE_REGISTRY set in /etc/sysconfig/docker so pulling the docker images fails because:

Nov 23 16:00:48 controller-0 dockerd-current: time="2018-11-23T16:00:48.154066648-05:00" level=error msg="Attempting next endpoint for pull after error: Get https://rhos-compute-node-08.lab.eng.rdu2.redhat.com:5000/v1/_ping: x509: certificate signed by unknown authority"


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-9.0.1-0.20181013060890.el7ost.noarch
openstack-tripleo-common-9.4.1-0.20181012010878.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
openstack overcloud deploy \
--timeout 100 \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack overcloud \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/enable-tls.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-endpoints-public-ip.yaml \
-e /home/stack/virt/hostnames.yml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/rhsm.yaml \
-e ~/containers-prepare-parameter.yaml \
-e /home/stack/virt/overcloud_satellite.yaml \
--log-file overcloud_deployment_76.log


Actual results:
Deployment fails because overcloud nodes are unable to pull images

Expected results:
Deployment succeeds.

Additional info:

Comment 2 Marius Cornea 2018-11-23 21:09:27 UTC
Created attachment 1508319 [details]
/var/lib/mistral/overcloud

Attaching /var/lib/mistral/overcloud

Comment 8 Steve Baker 2018-11-25 22:02:28 UTC
Assigning to docs for triage, we need to document when it is required to set a value for DockerInsecureRegistryAddress

Comment 23 errata-xmlrpc 2019-01-11 11:55:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.