Bug 1653021 - gnome-documents does not work, cannot find libgdprivate
Summary: gnome-documents does not work, cannot find libgdprivate
Keywords:
Status: CLOSED DUPLICATE of bug 1654178
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-documents
Version: 29
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Elad Alfassa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-24 16:07 UTC by Jerry James
Modified: 2019-03-20 13:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-20 13:14:01 UTC


Attachments (Terms of Use)

Description Jerry James 2018-11-24 16:07:21 UTC
Description of problem:

Launching gnome-documents opens a window, but nothing can be done with it.  It does not fetch any documents.  I found this in the system logs:

Nov 24 08:48:40 localhost.localdomain gnome-documents[3745]: Failed to load shared library 'libgdprivate-1.0.so' referenced by the typelib: libgdprivate-1.0.so: cannot open shared object file: No such file or directory
Nov 24 08:48:40 localhost.localdomain gnome-documents[3745]: JS ERROR: GLib.Error g-invoke-error-quark: Could not locate gd_filename_strip_extension: libgdprivate-1.0.so: cannot open shared object file: No such file or directory
Nov 24 08:48:40 localhost.localdomain gnome-documents[3745]: JS ERROR: GLib.Error g-invoke-error-quark: Could not locate gd_filename_strip_extension: (null)
Nov 24 08:48:40 localhost.localdomain gnome-documents[3745]: JS ERROR: GLib.Error g-invoke-error-quark: Could not locate gd_filename_strip_extension: (null)
Nov 24 08:48:41 localhost.localdomain gnome-documents[3745]: JS ERROR: GLib.Error g-invoke-error-quark: Could not locate gd_filename_strip_extension: (null)

Version-Release number of selected component (if applicable):
gnome-documents-3.30.0-1.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Launch gnome-documents
2. Look at a blank gray window with no contents
3.

Actual results:
No documents are found, even though I have some.

Expected results:
I should see my documents.

Additional info:

Comment 1 Christian Stadelmann 2019-02-17 12:23:34 UTC
This is a packaging bug.

Workaround: install gnome-documents

Comment 2 Debarshi Ray 2019-03-20 13:14:01 UTC

*** This bug has been marked as a duplicate of bug 1654178 ***


Note You need to log in before you can comment on or make changes to this bug.