Bug 1653033 - Missing DLL
Summary: Missing DLL
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-viewer
Version: unspecified
Hardware: x86_64
OS: Windows
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact:
URL:
Whiteboard:
Depends On: 1619740
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-24 22:03 UTC by Oliver
Modified: 2019-03-11 12:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-11 12:58:30 UTC


Attachments (Terms of Use)

Description Oliver 2018-11-24 22:03:36 UTC
Description of problem:

I installed the virt-viewer-x64-7.0.msi Windows Installer Database after verifying the supplied signature.

It was a bit surprising to get no desktop or start menu entry, but after consulting the log file, I noticed where it had been installed and headed there.

Starting any of the following executables gave me an error that libdl.dll could not be found on my system. I searched the whole C: drive for it and came up empty as well.

* virsh.exe
* virt-viewer.exe

The following program failed an assertion and showed a WER dialog:

* windows-cmdline-wrapper.exe (windows-cmd-wrapper.c:63)

The following other programs also complained about missing libraries:

* orc-bugreport.exe -> liborc-test-0.4-0.dll (file not found on C:)
* pango-view.exe -> libharfbuzz-0.dll (file not found on C:)

Furthermore

* gspawn-win64-helper.exe showed a WER dialog
* gspawn-win64-helper-console.exe showed a WER dialog (failed assertion in gspawn-win32-helper.c:208)

Version-Release number of selected component (if applicable):

7.0, I'd guess?!

How reproducible:


Steps to Reproduce:
1. Install on a fully patched Windows 7 x64 Ultimate
2. Attempt to run any of the programs
3. Observe symptoms

Actual results:

Errors as detailed in the description above.

Expected results:

Running programs :)

Additional info:

Ask me! At this point I am not sure what more information might be relevant.

remote-viewer.exe did not cause an issue, so I am hoping that's the component I am looking for (the viewer for remotely running KVM guests).

Comment 1 Oliver 2018-11-24 23:19:14 UTC
Yep, remote-viewer.exe was the component I was after and it works like a charm through an SSH tunnel. So the issue is a non-issue for me, but I hope it will help you to improve the software.

Comment 2 wes 2019-02-07 01:57:15 UTC
I am also having this issue. Windows 7, virt-viewer version 7.0-256.

Comment 3 Daniel Berrangé 2019-02-12 14:55:49 UTC
The msitools package is shipping outdated / broken content causing the generated installers to be broken.

Comment 4 Daniel Berrangé 2019-02-14 09:46:22 UTC
Fixed the msitools data upstream, so next virt-viewer windows builds should address the problems on this bug https://gitlab.gnome.org/GNOME/msitools/commit/db240b28808247efa92a0c240a737c18d300fdde

Comment 5 Daniel Berrangé 2019-03-11 12:58:30 UTC
The new 8.0 release should address all missing DLLs.


Note You need to log in before you can comment on or make changes to this bug.