Bug 1653089 - dell xps 9575 unreliable suspend/resume
Summary: dell xps 9575 unreliable suspend/resume
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-25 16:34 UTC by jan p. springer
Modified: 2019-02-10 21:43 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-30 13:08:39 UTC


Attachments (Terms of Use)
journalctl --no-hostname -k -b -1 (26.48 KB, application/x-gzip)
2018-12-03 22:58 UTC, jan p. springer
no flags Details

Description jan p. springer 2018-11-25 16:34:06 UTC
Description of problem:

moving from a xps 9560 to a xps 9575 system, suspend/resume cycles become unreliable making the laptop almost unusable

Version-Release number of selected component (if applicable):

up-to-date fedora 29

How reproducible:

always

Steps to Reproduce:
1. close laptop lid to suspend
2. open lid again for resume
3.

Actual results:

most of the time the laptop will be stuck in the suspend cycle

Expected results:

laptop resumes to working state

Additional info:

unfortunately there are no log entries indicating what the problem is

Comment 1 jan p. springer 2018-12-03 22:58:19 UTC
Created attachment 1511138 [details]
journalctl --no-hostname -k -b -1

Comment 2 Justin M. Forbes 2019-01-29 16:13:14 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 4.20.5-200.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 3 jan p. springer 2019-01-30 13:08:39 UTC
i can confirm that starting w/ the 4.20 kernel series suspend/resume cycles are working again for xps 9575 systems provided that wireless networking is disabled before suspend action.


Note You need to log in before you can comment on or make changes to this bug.