Bug 1653183 - Unable to update becase of glibc-headers.i686
Summary: Unable to update becase of glibc-headers.i686
Keywords:
Status: CLOSED DUPLICATE of bug 1652872
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 07:46 UTC by Daniel
Modified: 2018-11-26 07:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 07:59:09 UTC


Attachments (Terms of Use)

Description Daniel 2018-11-26 07:46:14 UTC
Description of problem:
Unable to update becase of glibc-headers.i686

Version-Release number of selected component (if applicable):
$ rpm -qa glibc\* | sort
glibc-2.28-17.fc29.i686
glibc-2.28-17.fc29.x86_64
glibc-common-2.28-17.fc29.x86_64
glibc-debuginfo-2.20-8.fc21.x86_64
glibc-debuginfo-common-2.20-8.fc21.x86_64
glibc-devel-2.28-17.fc29.i686
glibc-devel-2.28-17.fc29.x86_64
glibc-headers-2.28-17.fc29.i686
glibc-headers-2.28-17.fc29.x86_64
glibc-langpack-en-2.28-17.fc29.x86_64
glibc-langpack-ja-2.28-17.fc29.x86_64
glibc-langpack-zh-2.28-17.fc29.x86_64


How reproducible:
Everytime

Steps to Reproduce:
1. run "sudo dnf update"

Actual results:
$ sudo dnf update glibc\*
Contacting OpenClient Router for restricted repository information
Open Client for Linux Fedora 29 x86_64 - Commun 2.0 kB/s | 3.6 kB     00:01    
Dependencies resolved.

 Problem: cannot install both glibc-headers-2.28-20.fc29.x86_64 and glibc-headers-2.28-17.fc29.x86_64
  - glibc-headers-2.28-17.fc29.i686 has inferior architecture
  - cannot install the best update candidate for package glibc-headers-2.28-17.fc29.x86_64
  - problem with installed package glibc-headers-2.28-17.fc29.i686
================================================================================
 Package              Arch          Version                Repository      Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 glibc-headers        x86_64        2.28-20.fc29           updates        463 k

Transaction Summary
================================================================================
Skip  1 Package

Nothing to do.
Complete!


Expected results:
glibc-headers.i686 of version 2.28-20.fc29 should also be provided.

Additional info:

Comment 1 Florian Weimer 2018-11-26 07:59:09 UTC

*** This bug has been marked as a duplicate of bug 1652872 ***


Note You need to log in before you can comment on or make changes to this bug.