Bug 165323 - file -i returns wrong mimetype for mpeg1 video
file -i returns wrong mimetype for mpeg1 video
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-07 17:56 EDT by Sergey Bostandzhyan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.14-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 08:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey Bostandzhyan 2005-08-07 17:56:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
I have various mpeg1 video files; on FC3 (file-4.12-1.FC3.1) the file -i command returned the video/mpeg mimetype for those files, that was correct.

On FC4 file -i returns "FFF6    0xFFF0          audio/X-HX-AAC-ADTS" which is not correct. 

The problem appeared with a number of files, not only with one.
Use this video if you can not reproduce it with your data:
http://www.deadlock.dhs.org/~jin/blender/heusl.mpg

Version-Release number of selected component (if applicable):
file-4.13-4

How reproducible:
Always

Steps to Reproduce:
1. get an mpeg 1 video file, assuming "yourfile.mpg"
2. enter "file -i yourfile.mpg" in terminal and look at the output


Actual Results:  mimetype information was: "FFF6    0xFFF0          audio/X-HX-AAC-ADTS"


Expected Results:  mimetype information should be "video/mpeg"

Additional info:
Comment 1 Sergey Bostandzhyan 2005-08-07 18:03:16 EDT
The problem seems to be related to the magic.mime file that has changed from FC3
to FC4. 

Using the magic.mime file from FC3 with the -m option on a FC4 system produces
correct output. (something like: file -i myfile.mpg -m /tmp/fc3_magic.mime)
Comment 2 Radek Vokal 2005-08-09 08:46:00 EDT
Fixed, there was a typo in AAC files recognition. 

Note You need to log in before you can comment on or make changes to this bug.