Bug 1653231 - [RHV 4.2.7] Uncaught exception while adding vmware as an external provider
Summary: [RHV 4.2.7] Uncaught exception while adding vmware as an external provider
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.7
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ovirt-4.2.8
: ---
Assignee: Steven Rosenberg
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 10:39 UTC by Ulhas Surse
Modified: 2019-08-28 13:15 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 12:44:51 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3722771 None None None 2018-11-29 05:14:20 UTC
Red Hat Product Errata RHBA-2019:0121 None None None 2019-01-22 12:44:59 UTC

Description Ulhas Surse 2018-11-26 10:39:23 UTC
Description of problem:
When trying to add VMware as an external provider from web admin, the "Add" page -> "ok" and "test" buttons are not functioning at all.

Version-Release number of selected component (if applicable):
ovirt-engine-dashboard-1.2.4-1.el7ev.noarch
ovirt-engine-4.2.7.4-0.1.el7ev.noarch

How reproducible:
Always 100%

Steps to Reproduce:
1. Try to add an external provider. (tried with VMWare)
2. After entering all the details, press OK or test.
3. Exception caught: undefined

Actual results:
Error and unable to add an external provider.

Expected results:
Should be able to add an external provider VMWare without any error. 

Additional info:

ui.log

~~~
2018-11-26 15:55:41,999+05 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-31) [] Permutation name: 8E06E97A9C294F973EFA8B881B42B45F
2018-11-26 15:55:42,000+05 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-31) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: undefined
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_191]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_191]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at Unknown.new Q0(webadmin-0.js)
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1415) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:312) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js)
Caused by: java.lang.ClassCastException
        at java.lang.Throwable.Throwable(Throwable.java:59) [rt.jar:1.8.0_191]
        at java.lang.Exception.Exception(Exception.java:25) [rt.jar:1.8.0_191]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:25) [rt.jar:1.8.0_191]
        at Unknown.new PHf(webadmin-0.js)
        at javaemul.internal.InternalPreconditions.checkCriticalType(InternalPreconditions.java:139) [gwt-servlet.jar:]
        at com.google.gwt.lang.Cast.castTo(Cast.java:74)
        at org.ovirt.engine.ui.uicommonweb.models.providers.ProviderModel.$getOpenStackProviderProperties(ProviderModel.java:668)
        at org.ovirt.engine.ui.uicommonweb.models.providers.ProviderModel.$flush(ProviderModel.java:605)
        at org.ovirt.engine.ui.uicommonweb.models.providers.ProviderModel.$onTest(ProviderModel.java:699)
        at org.ovirt.engine.ui.uicommonweb.models.providers.EditProviderModel.executeCommand(EditProviderModel.java:161)
        at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
        at org.ovirt.engine.ui.webadmin.section.main.presenter.popup.provider.ProviderPopupPresenterWidget$lambda$0$Type.onClick(ProviderPopupPresenterWidget.java:30)
        at com.google.gwt.event.dom.client.ClickEvent.dispatch(ClickEvent.java:55) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        ... 11 more
~~~

Comment 7 Steven Rosenberg 2018-12-06 18:08:00 UTC
I tested this. One needs to uncheck the "Verify server's SSL certificate" and then it works as per the entries from the screen shot. Which means SSL certificate is not configured on the server, so the checkbox should not be checked.

Comment 8 Steven Rosenberg 2018-12-11 15:07:08 UTC
I checked this issue with the current master (RHV 4.3), RHV 4.2.8 and RHV 4.2.7.6. RHV 4.2.7.6 does display the Tenant Name Label and Text Box when vmware is set along with other issues, but not in the later versions. Please test this with RHV 4.2.8 which seems to have fixed this issue as per my checking.

Comment 11 Nisim Simsolo 2018-12-16 10:02:10 UTC
Verified:
ovirt-engine-4.2.8.1-0.1.el7ev
vdsm-4.20.45-1.el7ev.x86_64
qemu-kvm-rhev-2.12.0-18.el7_6.3.x86_64
libvirt-client-4.5.0-10.el7_6.3.x86_64

Comment 13 errata-xmlrpc 2019-01-22 12:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0121

Comment 14 Daniel Gur 2019-08-28 13:11:42 UTC
sync2jira

Comment 15 Daniel Gur 2019-08-28 13:15:55 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.