Bug 1653267 - update of openshift-metrics project from 3.7 to 3.9 fails
Summary: update of openshift-metrics project from 3.7 to 3.9 fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.9.z
Assignee: Jan Martiska
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 12:12 UTC by Vladislav Walek
Modified: 2019-07-09 18:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1661841 1662925 (view as bug list)
Environment:
Last Closed: 2019-07-09 18:26:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3748 None None None 2018-12-13 19:27:27 UTC

Description Vladislav Walek 2018-11-26 12:12:50 UTC
Description of problem:

The installer fails on the task:
TASK [openshift_metrics : Applying /tmp/openshift-metrics-ansible-fS4rZe/templates/hawkular-rolebinding.yaml] ***

The error is:
The clusterrolebindings \"hawkular-view\" is invalid: subjects[0].namespace: Required value"

The problem is here:
https://github.com/openshift/openshift-ansible/blob/release-3.9/roles/openshift_metrics/tasks/generate_rolebindings.yaml#L14

There is no namespace in the definition, but the j2 template requires that.

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

line:
namespace: "{{openshift_metrics_project}}"

In https://github.com/openshift/openshift-ansible/blob/release-3.9/roles/openshift_metrics/tasks/generate_rolebindings.yaml#L14

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Junqi Zhao 2018-12-03 03:28:44 UTC
issue is fixed with
# rpm -qa | grep ansible
openshift-ansible-docs-3.9.57-1.git.0.9ece605.el7.noarch
ansible-2.4.6.0-1.el7ae.noarch
openshift-ansible-playbooks-3.9.57-1.git.0.9ece605.el7.noarch
openshift-ansible-3.9.57-1.git.0.9ece605.el7.noarch
openshift-ansible-roles-3.9.57-1.git.0.9ece605.el7.noarch

Comment 6 errata-xmlrpc 2018-12-13 19:27:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3748

Comment 10 Junqi Zhao 2018-12-24 01:15:29 UTC
I have cloned this bug for OCP v3.10, see Bug 1661841
Close this bug


Note You need to log in before you can comment on or make changes to this bug.