Bug 1653277 - bump up default value of server.event-threads
Summary: bump up default value of server.event-threads
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Milind Changire
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1652537
TreeView+ depends on / blocked
 
Reported: 2018-11-26 12:29 UTC by Milind Changire
Modified: 2019-03-25 16:32 UTC (History)
5 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1652537
Environment:
Last Closed: 2019-03-25 16:32:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21719 0 None Merged rpc: bump up server.event-threads 2018-12-04 06:39:41 UTC

Comment 1 Milind Changire 2018-11-26 12:30:03 UTC
Rationale:
Heavy IO keeps the single event-thread busy with reading messages from the
network and queuing them to the request handler threads. Messages remain unread
at the socket while the request is being queued to the request handler threads.
Time is thus wasted while messages accumulate in the socket buffers. To achieve
better responsiveness and thus avoid ping-timer expiry, it has been observed
that multiple event-threads help in achieving the same. Additional event-threads
help in improving system performance as well since they help in reading requests
sooner and get them serviced sooner than they would with the single event-thread
model.

Therefore the need to bump up the default value of event-threads to a better
value.

Comment 2 Worker Ant 2018-11-26 12:32:37 UTC
REVIEW: https://review.gluster.org/21719 (rpc: bump up server.event-threads) posted (#2) for review on master by Milind Changire

Comment 3 Worker Ant 2018-12-04 06:39:40 UTC
REVIEW: https://review.gluster.org/21719 (rpc: bump up server.event-threads) posted (#4) for review on master by Raghavendra G

Comment 4 Shyamsundar 2019-03-25 16:32:14 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.