Bug 16533 - Solaris NFS server mount fails for Pinstripe's bootnet.img
Solaris NFS server mount fails for Pinstripe's bootnet.img
Status: CLOSED DUPLICATE of bug 17069
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-18 10:29 EDT by Roman Czyborra
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 11:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Czyborra 2000-08-18 10:29:02 EDT
On cindy.hal.taz.de I insert a boot floppy created with
dd if=pinstripe-en-i386-cd1/images/bootnet.img of=/dev/fd0,
boot text brings up the installation dialog,
I can select language, keyboard, NFS intallation, 
BOOTP configuration succeeds,
lets me enter the NFS address

But then the NFS mount allegedly fails and Pinstripe won't install
even though the NFS server says that the mount succeeded:

# uname -a
SunOS singh05 5.6 Generic_105181-03 sun4u sparc
# snoop host cindy
Using device /dev/hme (promiscuous mode)
cindy.hal.taz.de -> singh05.hal.taz.de TCP D=111 S=632 Syn Seq=2258630233
Len=0 Win=16060
singh05.hal.taz.de -> cindy.hal.taz.de TCP D=632 S=111 Syn Ack=2258630234
Seq=477079516 Len=0 Win=10136
cindy.hal.taz.de -> singh05.hal.taz.de TCP D=111 S=632     Ack=477079517
Seq=2258630234 Len=0 Win=16060
cindy.hal.taz.de -> singh05.hal.taz.de PORTMAP C DUMP
singh05.hal.taz.de -> cindy.hal.taz.de TCP D=632 S=111     Ack=2258630278
Seq=477079517 Len=0 Win=10092
singh05.hal.taz.de -> cindy.hal.taz.de PORTMAP R DUMP 68 map(s) found
cindy.hal.taz.de -> singh05.hal.taz.de TCP D=111 S=632     Ack=477080909
Seq=2258630278 Len=0 Win=14668
cindy.hal.taz.de -> singh05.hal.taz.de TCP D=111 S=632 Fin Ack=477080909
Seq=2258630278 Len=0 Win=16060
singh05.hal.taz.de -> cindy.hal.taz.de TCP D=632 S=111     Ack=2258630279
Seq=477080909 Len=0 Win=10136
singh05.hal.taz.de -> cindy.hal.taz.de TCP D=632 S=111 Fin Ack=2258630279
Seq=477080909 Len=0 Win=10136
cindy.hal.taz.de -> singh05.hal.taz.de MOUNT3 C Mount /redhat
cindy.hal.taz.de -> singh05.hal.taz.de TCP D=111 S=632     Ack=477080910
Seq=2258630279 Len=0 Win=16060
singh05.hal.taz.de -> cindy.hal.taz.de MOUNT3 R Mount OK FH=0085 Auth=unix
cindy.hal.taz.de -> singh05.hal.taz.de PORTMAP C GETPORT prog=100003 (NFS)
vers=3 proto=UDP
singh05.hal.taz.de -> cindy.hal.taz.de PORTMAP R GETPORT port=2049
# showmount -a
cindy.hal.taz.de:/mloc/share/redhat

The Pinstripe beta has no such problem with NFS servers
running various Linuxes or SunOS 4, there I get the 
"no RedHat" error message as those servers do not carry
the RedHat/instimage/.  But it has this problem with
all of our Solaris 2.6 or 7 servers and me thinks that Sun's
NFS implementation cannot be considered very nonstandard!

Unfortunately the RedHat installer's error message is not very verbose.
Is there an explanation and a fix for this?
Comment 1 Alan Cox 2000-08-18 10:35:10 EDT
singh05.hal.taz.de -> cindy.hal.taz.de MOUNT3 R Mount OK FH=0085 Auth=unix
 cindy.hal.taz.de -> singh05.hal.taz.de PORTMAP C GETPORT prog=100003 (NFS)
 vers=3 proto=UDP
 singh05.hal.taz.de -> cindy.hal.taz.de PORTMAP R GETPORT port=2049
 # showmount -a
 cindy.hal.taz.de:/mloc/share/redhat

That is completing an NFSv3 mount request while the kernel only supports NFSv2
Comment 2 Matt Wilson 2000-10-25 15:02:38 EDT

*** This bug has been marked as a duplicate of 17069 ***

Note You need to log in before you can comment on or make changes to this bug.