Bug 1653412 - [v2v] Kill/Terminate virt-v2v processes and cleanup environments if migration plan is marked failed in CFME
Summary: [v2v] Kill/Terminate virt-v2v processes and cleanup environments if migration...
Keywords:
Status: CLOSED DUPLICATE of bug 1653407
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Fabien Dupont
QA Contact: Kedar Kulkarni
Red Hat CloudForms Documentation
URL:
Whiteboard: v2v
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 19:09 UTC by Kedar Kulkarni
Modified: 2018-12-14 19:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 17:28:24 UTC
Category: ---
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)

Description Kedar Kulkarni 2018-11-26 19:09:14 UTC
Description of problem:
When I came across bz1653407, I realized that migration was not killed/terminated/cancelled on backend within Conversion host, while CFME UI thinks it is failed. Hence,Kill/Terminate virt-v2v processes and cleanup environments if migration plan is marked failed in CFME. This was encountered with OSP migration but we should make it consistent for OSP and RHV both, that we will cleanup virt-v2v processes and cleanup target environments if we are showing migration has failed in UI to our customers. 


Version-Release number of selected component (if applicable):
5.10.0.24

How reproducible:
I was able to reproduce only when migrations are extremely slow


Steps to Reproduce:
1.Add VMware and OSP providers and setup them for migration
2.Configure conversion appliance
3.Create infra map and migration plan
4.Run migration

Actual results:
CFME UI shows migration failed, while virt-v2v is running on the conversion appliance and migration eventually would succeed or fail. 

Expected results:
Kill/Terminate virt-v2v processes and cleanup environments if migration plan is marked failed in CFME  

Additional info:

Comment 4 Brett Thurber 2018-12-10 17:28:24 UTC

*** This bug has been marked as a duplicate of bug 1653407 ***


Note You need to log in before you can comment on or make changes to this bug.