Bug 165349 - "yum clean all" saves 1.4GB of .... what?
"yum clean all" saves 1.4GB of .... what?
Status: CLOSED DUPLICATE of bug 165348
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 09:13 EDT by james
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 10:11:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2005-08-08 09:13:13 EDT
From Bugzilla Helper:
User-Agent: Opera/8.0 (X11; Linux i686; U; en)

Description of problem:
$ sudo yum clean all
Cleaning up Everything
0 headers removed
0 packages removed
0 metadata files removed
0 cache files removed
0 cache files removed

$ du -sch /var/cache/yum/*
14M     /var/cache/yum/base
4.9M    /var/cache/yum/dag
296M    /var/cache/yum/development
116K    /var/cache/yum/extras
402M    /var/cache/yum/extras-stable
171M    /var/cache/yum/extras-testing
32K     /var/cache/yum/flash
427M    /var/cache/yum/pre-extras
100K    /var/cache/yum/updates-released
35M     /var/cache/yum/updates-testing
1.4G    total

This looks to me like 1.4GB (!) of wasted space an my "getting full" hard drive.  Everything I want to install with 
yum has already been installed.  Why is yum saving 1.4GB of headers and packages after "yum clean all".  This 
looks like a bug to me.





Version-Release number of selected component (if applicable):
yum-2.3.2-7

How reproducible:
Always

Steps to Reproduce:
1.yum clean all
2.
3.
  

Actual Results:  $du -sch /var/cache/yum/*
...
1.4G    total

Expected Results:  remove all headers, packages, metadata, and cached files from /var/cache/yum.

Additional info:

Say whether or not there is any substantive, valid reason not to simply do "rm -R /var/cache/yum/*".
Comment 1 Seth Vidal 2005-08-08 10:11:36 EDT

*** This bug has been marked as a duplicate of 165348 ***

Note You need to log in before you can comment on or make changes to this bug.