Bug 165352 - RHEL4U2 Emulex driver update 2
RHEL4U2 Emulex driver update 2
Status: CLOSED DUPLICATE of bug 158789
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-08-08 10:03 EDT by Linda Wang
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-08 17:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Linda Wang 2005-08-08 10:03:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
Emulex has recently found several serious bugs in the the lpfc driver
version we have in U2.  The most critical is a fix for a race between
eh_abort handler and the scsi_done up-call:

"This allowed premature scsi completions, which in our tests have lead
to data corruption.  As such, we'd like very much to have this updated
driver in RHEL4u2."

The fix is to hold the host_lock in driver's done routine. 

There are several other serious bug fixes since late May when they sent
us the driver we currently have in U2. These include various error
handling and stability issues, including the FAN issue that I just
posted for Taroon. The complete changelog is attached.

Unfortunately, there are also a bunch of less important changes in their
current revision, including a pile of annoying copyright changes, etc. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot the kernel with emulax driver
2.run some disk related tests

Additional info:

We need to make a difficult decision about whether to take their latest
revision as-is, so we stay in synch with the testing that Emulex and our
shared OEMs are doing, or whether we should minimize change in the U2
stream, by forcing Emulex to give is a custom driver that only has very
critical bug fixes. My opinion is that we are better off staying in sync
with the rest of the world, because their FC testing is much more
thorough than ours and all of our beta testers combined. 

I have reviewed this patch in detail, and I don't see anything that adds
risk w.r.t. interaction with the Linux SCSI subsystem. I have also built
it and done some regression testing. I have been told that EMC, IBM and
others are already testing this driver revision as well.
Comment 1 Linda Wang 2005-08-08 17:30:03 EDT

*** This bug has been marked as a duplicate of 158789 ***

Note You need to log in before you can comment on or make changes to this bug.