Bug 1653576 - [RHHI-V] Support single brick distribute volume for RHHI-V volumes
Summary: [RHHI-V] Support single brick distribute volume for RHHI-V volumes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: RHHI-V 1.6
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1653575
Blocks: RHHI-V-1-6-Engineering-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2018-11-27 07:32 UTC by SATHEESARAN
Modified: 2019-05-09 06:09 UTC (History)
5 users (show)

Fixed In Version: gluster-ansible-features-1.0.4-2
Doc Type: Enhancement
Doc Text:
Distributed volume support has been added to Red Hat Hyperconverged Infrastructure for Virtualization 1.6, for use with single node deployments only, using gluster-ansible roles.
Clone Of: 1653575
Environment:
Last Closed: 2019-05-09 06:09:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1121 None None None 2019-05-09 06:09:43 UTC

Description SATHEESARAN 2018-11-27 07:32:11 UTC
Description of problem:
-----------------------
Currently the RHGS volumes created for RHHI-V are of replica 3 or arbitrated replica 3 volume only. RHHI-V also supports single brick volume. For this use case, gluster-ansible role should support creation of single brick volume ( distribute volume with single brick )

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHHI-V 1.5.z
gluster-ansible-roles-1.0.4

How reproducible:
-----------------
Not applicable

Steps to Reproduce:
-------------------
1. Try to create single brick distribute RHGS volume by having single host entry

Actual results:
---------------
No way to create single brick distribute volume

Expected results:
-----------------
gluster-ansible role should support single brick distribute volume

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-11-27 02:31:00 EST ---

This bug is automatically being proposed for a Z-stream release of Red Hat Gluster Storage 3 under active development and open for bug fixes, by setting the release flag 'rhgs‑3.4.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

Comment 1 Sachidananda Urs 2018-12-26 06:03:27 UTC
Commit: https://github.com/gluster/gluster-ansible-features/commit/99b688dcdd50 fixes the issue.

Comment 4 SATHEESARAN 2019-02-23 17:53:14 UTC
Dependent bug is already ON_QA and moving this bug too to ON_QA

Comment 5 SATHEESARAN 2019-02-23 17:53:32 UTC
Tested with gluster-ansible-features-1.0.4-3

distributed volume is created as part of single node deployment and required volume options are set on it

Comment 7 errata-xmlrpc 2019-05-09 06:09:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1121


Note You need to log in before you can comment on or make changes to this bug.