Bug 1653580 - rgw: unauthenticated (or empty) request causes segfault in RGW
Summary: rgw: unauthenticated (or empty) request causes segfault in RGW
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 3.2
Assignee: Matt Benjamin (redhat)
QA Contact: sagrawal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 07:40 UTC by sagrawal
Modified: 2019-01-03 19:02 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-12.2.8-46.el7cp Ubuntu: ceph_12.2.8-43redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:34 UTC

Description sagrawal 2018-11-27 07:40:18 UTC
Description of problem:
In a newly installed cluster, the curl command to rgw node is returning "Empty reply from server"

Version-Release number of selected component (if applicable):
ceph version 12.2.8-39.el7cp

How reproducible:
Always

Steps to Reproduce:
1. Install rgw node using ansible playbook
2. Do curl on rgw node from ansible
eg.
[ubuntu@magna019 ~]$ curl http://rgw:8080
curl: (52) Empty reply from server

3. However curl command is successful on other processes like osd.
eg.
[ubuntu@magna019 ~]$ curl http://osd:6800
ceph v027P�
���
^C

Actual results:
The curl command to rgw node returns "curl: (52) Empty reply from server".

Expected results:
The curl command to rgw node should work.

Additional info:
However, the curl command was successful and working on ceph version 12.2.8-36.el7cp

Comment 24 errata-xmlrpc 2019-01-03 19:02:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.