Bug 1653626 - [cloud] controller-manager logs output nil when update machineset replicas
Summary: [cloud] controller-manager logs output nil when update machineset replicas
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Jan Chaloupka
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 10:17 UTC by sunzhaohua
Modified: 2019-06-04 10:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:09 UTC

Description sunzhaohua 2018-11-27 10:17:36 UTC
Description of problem:
update machineset replicas controller-manager logs output nil

Version-Release number of selected component (if applicable):
$ ./openshift-install version
./openshift-install v0.4.0-8-gcc10f8027c30a37a8c3d78b793587126208c9d68-dirty
Terraform v0.11.8


$ oc version
oc v4.0.0-alpha.0+9750828-637
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:
always


Steps to Reproduce:
1. $ oc edit  machineset qe-zhsun-1-worker-us-east-2a
2. $ oc logs -f clusterapi-manager-controllers-5b4996fb88-bzst7 -c controller-manager
3.

Actual results:
controller-manager logs output nil

$ oc logs -f clusterapi-manager-controllers-5b4996fb88-bzst7 -c controller-manager
2018/11/26 02:13:13 Registering Components.
2018/11/26 02:13:13 Starting the Cmd.
E1126 02:13:14.009211       1 controller.go:370] <nil>
E1126 02:13:14.129338       1 controller.go:370] <nil>
E1126 02:13:14.248753       1 controller.go:370] <nil>
E1126 02:13:41.332806       1 reflector.go:322] sigs.k8s.io/cluster-api-provider-aws/vendor/sigs.k8s.io/controller-runtime/pkg/cache/internal/informers_map.go:126: Failed to watch *v1.Node: Get https://172.30.0.1:443/api/v1/nodes?resourceVersion=3347&timeoutSeconds=346&watch=true: dial tcp 172.30.0.1:443: connect: connection refused
E1126 02:13:41.333000       1 reflector.go:322] sigs.k8s.io/cluster-api-provider-aws/vendor/sigs.k8s.io/controller-runtime/pkg/cache/internal/informers_map.go:126: Failed to watch *v1alpha1.MachineDeployment: Get https://172.30.0.1:443/apis/cluster.k8s.io/v1alpha1/machinedeployments?resourceVersion=867&timeoutSeconds=506&watch=true: dial tcp 172.30.0.1:443: connect: connection refused
E1126 02:13:41.333062       1 reflector.go:322] sigs.k8s.io/cluster-api-provider-aws/vendor/sigs.k8s.io/controller-runtime/pkg/cache/internal/informers_map.go:126: Failed to watch *v1alpha1.MachineSet: Get https://172.30.0.1:443/apis/cluster.k8s.io/v1alpha1/machinesets?resourceVersion=2231&timeoutSeconds=319&watch=true: dial tcp 172.30.0.1:443: connect: connection refused

E1126 07:46:59.884834       1 controller.go:370] <nil>

Expected results:
controller-manager logs no nil info

Additional info:

Comment 2 Jan Chaloupka 2018-12-07 14:36:08 UTC
Merged upstream, next step is to sync cluster-api dep.

Comment 5 sunzhaohua 2019-01-11 09:26:14 UTC
Verified.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-11-000044   True        False         1h        Cluster version is 4.0.0-0.nightly-2019-01-11-000044

$ oc edit machineset zhsun-worker-us-east-2a
machineset.cluster.k8s.io/zhsun-worker-us-east-2a edited

controller-manager logs no nil info.

Comment 8 errata-xmlrpc 2019-06-04 10:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.