Bug 1653641 - UI exceptions observed when selecting the gluster volume
Summary: UI exceptions observed when selecting the gluster volume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.7.1
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.3.2
: ---
Assignee: Kaustav Majumder
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1653650
TreeView+ depends on / blocked
 
Reported: 2018-11-27 10:40 UTC by SATHEESARAN
Modified: 2019-03-19 10:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1653650 (view as bug list)
Environment:
Last Closed: 2019-03-19 10:03:22 UTC
oVirt Team: Gluster
pm-rhel: ovirt-4.3?
pm-rhel: ovirt-4.4?
sasundar: planning_ack?
pm-rhel: devel_ack+
bshetty: testing_ack+


Attachments (Terms of Use)
ui.log (105.58 KB, text/plain)
2018-11-27 10:44 UTC, SATHEESARAN
no flags Details

Description SATHEESARAN 2018-11-27 10:40:24 UTC
Description of problem:
------------------------
On the RHV Manager UI, when the gluster volume is selected, UI exceptions are seen

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHV 4.2.7-1
RHGS 3.4.1
RHHI-V 1.5

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Create gluster volume from RHV Manager UI or from RHGS cli
2. Select the volume from RHV Manager UI

Actual results:
---------------
UI exceptions is seen

Expected results:
-----------------
No UI exceptions should be seen


Additional info:

Comment 1 SATHEESARAN 2018-11-27 10:44:17 UTC
Created attachment 1508795 [details]
ui.log

Comment 2 Sandro Bonazzola 2019-01-28 09:42:12 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 3 Gobinda Das 2019-03-15 06:51:24 UTC
As per sas's comments in parent bugs (This issue is not seen with RHV 4.3 Beta) moving this to ON_QA.

Comment 4 Lucie Leistnerova 2019-03-18 07:24:56 UTC
Is it enough to verify on normal RHVM with gluster host or it is RHHI related?

Comment 5 bipin 2019-03-18 16:11:45 UTC
Lucie,

This was seen on a RHHI enviornment. So would be good enough to verify in that.

Comment 6 bipin 2019-03-19 03:47:21 UTC
Changing the target based on the comments made in the base bug.

Comment 7 bipin 2019-03-19 03:52:00 UTC
Verified the bug in the below mentioned components. Could not see any exceptions.


Components:
==========
ovirt-engine-4.3.2.1-0.1.el7.noarch
rhvh-4.3.0.5-0.20190313.0+1
glusterfs-3.12.2-47.el7rhgs.x86_64


Steps:
=====
1. Create gluster volume from RHV Manager UI or from RHGS cli
2. Select the volume from RHV Manager UI

Comment 8 Sandro Bonazzola 2019-03-19 10:03:22 UTC
This bugzilla is included in oVirt 4.3.2 release, published on March 19th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.