Bug 1653698 - No spice channel is added for Windows guests
Summary: No spice channel is added for Windows guests
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1660123
TreeView+ depends on / blocked
 
Reported: 2018-11-27 12:44 UTC by Radek Duda
Modified: 2019-06-15 00:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1660123 (view as bug list)
Environment:
Last Closed: 2019-06-15 00:57:58 UTC


Attachments (Terms of Use)

Description Radek Duda 2018-11-27 12:44:35 UTC
Description of problem:
If I create VM in Virtual Machine Manager, no spice channel is added to VM configuration.

Version-Release number of selected component (if applicable):
virt-manager-2.0.0-1.el8.noarch
libvirt-3.10.0-2.el8+526+412dc3e0.x86_64

How reproducible:
always

Steps to Reproduce:
1. Click 'Create new virtual machine' in virt-manager GUI
2. In step 2 choose 'Microsoft Windows 10' or 'Microsoft Windows Server 2016'
3. Proceed

Actual results:
No spice channel is added to Windows VM, so that spice-vdagent is not functional

Expected results:
Spice channel is added to guest

Additional info:

Comment 1 Cole Robinson 2018-12-13 21:35:40 UTC
This is intentional though there's pluses and minuses. The reasoning for removing it is that windows VMs installed by virt-manager by default don't support virtio. So we were attaching a virtio-serial channel to the VM (for spice) that default windows couldn't recognize. This means an unknown device in windows device manager for example.

If users then run spice-guest-tools or similar and install spice + virtio bits, they then need to manually add a spice channel to the VM. I'm okay with this tradeoff since there's already manual steps involved.

Longer term I'd like to make it easier to make windows+virtio 'just work' out of the box in virt-manager. This will involve libosinfo unattended install support like boxes uses, and possibly friendlier virtio-win iso behavior.

Comment 2 Cole Robinson 2019-06-15 00:57:58 UTC
I've revived this upstream now:

commit d40975c493a554d179cca1c5c888cacfc2c9cd41 (HEAD -> master, origin/master)
Author: Cole Robinson <crobinso@redhat.com>
Date:   Fri Jun 14 20:51:43 2019 -0400

    guest: Add back spice virtio-serial for windows


Note You need to log in before you can comment on or make changes to this bug.