Bug 1653699 - Openstack : Cloud provider supports LB although '[LoadBalancer]' section is missing in openstack.conf
Summary: Openstack : Cloud provider supports LB although '[LoadBalancer]' section is ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Jan Chaloupka
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 12:48 UTC by Yossi Boaron
Modified: 2019-01-30 15:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-30 15:19:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 21554 None None None 2018-11-28 14:53:46 UTC
Red Hat Product Errata RHBA-2019:0096 None None None 2019-01-30 15:19:36 UTC

Description Yossi Boaron 2018-11-27 12:48:14 UTC
Description of problem:

Cloud-provider LoadBalancer functionality seems to be active altough '[LoadBalancer]' section is empty or not present in openstack.cfg file.


Version-Release number of selected component (if applicable):

[openshift@master-0 ~]$ oc version
oc v3.11.44
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://192.168.99.6:8443
openshift v3.11.44
kubernetes v1.11.0+d4cacc0
[openshift@master-0 ~]$ 


How reproducible:

run shiftstack deployment with cloud provider enabled, but without any 'LoadBalancer' option, the relevant part from OSEv3.yml file:

"
openshift_cloudprovider_kind: openstack
openshift_cloudprovider_openstack_auth_url: "{{ lookup('env','OS_AUTH_URL') }}"
openshift_cloudprovider_openstack_username: "{{ lookup('env','OS_USERNAME') }}"
openshift_cloudprovider_openstack_password: "{{ lookup('env','OS_PASSWORD') }}"
openshift_cloudprovider_openstack_tenant_name: "{{ lookup('env','OS_PROJECT_NAME') }}"
openshift_cloudprovider_openstack_domain_name: "{{ lookup('env','OS_USER_DOMAIN_NAME') }}"
openshift_cloudprovider_openstack_blockstorage_version: v2
"


Actual results:

Openstack Cloud-provider LoadBalacer functionality is active.

Checking the master controllers logs, I can see that LB function is active.
'Claiming to support LoadBalancer'

This behavior could lead to conflict in a case 'Kuryr' is configured as the SDN.

Expected results:

Openstack Cloud-provider LoadBalance functionality should be disabled.

Additional info:

Seems that this bug was resolved in K8S 1.12 upstream.
https://github.com/kubernetes/kubernetes/blob/release-1.12/pkg/cloudprovider/providers/openstack/openstack.go#L589

Comment 1 Yossi Boaron 2018-11-27 12:55:01 UTC
Here is a link to upstream commit that fixes this issue:

https://github.com/kubernetes/kubernetes/commit/a78fc5926d6091fcae9df2ccac3a5a3182832ce4

Comment 2 Yossi Boaron 2018-11-27 15:13:58 UTC
I sent this PR upstream to address this issue:

https://github.com/openshift/origin/pull/21554

Comment 4 Jan Chaloupka 2018-12-05 13:06:56 UTC
Hi Yossi,

thanks for the PR and resolution of the issue.

Jan

Comment 6 Chao Yang 2019-01-17 05:37:49 UTC
It is passed on
openshift v3.11.69
kubernetes v1.11.0+d4cacc0

[root@qe-chaoyang-master-etcd-nfs-1 ~]# oc logs master-controllers-qe-chaoyang-master-etcd-nfs-1 | grep LoadBalancer
I0117 03:25:57.969058       1 openstack.go:575] openstack.LoadBalancer() called
I0117 03:25:57.969093       1 openstack.go:578] LoadBalancer section is empty/not defined in cloud-config

Comment 8 errata-xmlrpc 2019-01-30 15:19:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0096


Note You need to log in before you can comment on or make changes to this bug.