Bug 1653727 - python-neutron-tests package dependences made update fail
Summary: python-neutron-tests package dependences made update fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z7
: 13.0 (Queens)
Assignee: Carlos Camacho
QA Contact: Roee Agiman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 13:56 UTC by Eduard Barrera
Modified: 2019-07-10 13:05 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.3.1-34.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 13:03:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1738 None None None 2019-07-10 13:05:16 UTC

Description Eduard Barrera 2018-11-27 13:56:04 UTC
Description of problem:

We got this error during an update.

Error: Package: 1:python-neutron-tests-9.4.1-19.el7ost.noarch 
           Requires: python-neutron = 1:9.4.1-19.el7ost
           Removing: 1:python-neutron-9.4.1-19.el7ost.noarch 
               python-neutron = 1:9.4.1-19.el7ost


Perhaps depndences could be changed to  >=  to avoid the error


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install python-neutron-tests
2. do a FFW update
3.

Actual results:
update fails

Expected results:
no failures

Comment 1 Brian Haley 2018-12-06 16:56:29 UTC
We were wondering if this was more of a problem for the Upgrades DFG?  I'll add them to the whiteboard and ping them to consult.

Comment 2 Jose Luis Franco 2018-12-10 13:41:21 UTC
Could you please specify in which step of the FFWD upgrade process this is happening? When you mentioned, "during an update", was it a minor-updete prior the FFWD upgrade?

Thanks.

Comment 3 Eduard Barrera 2018-12-10 14:11:11 UTC
Hi,

during  # openstack overcloud ffwd-upgrade run

Comment 9 Carlos Camacho 2019-02-25 15:35:34 UTC
So, the root cause of the issue is that python-neutron-tests is not available anymore in OSP that's why the package upgrade fails.

I'm speaking with the release delivery team to see if we can have that package in OSP

Comment 12 Nate Johnston 2019-02-25 20:11:50 UTC
There was a similar bug [1] also for OSP 10 with the removal of the openstack-neutron-bgp-dragent package.  The solution was a change to the specfile [2].  Since this sounds like a similar situation, perhaps a similar fix can be used.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1599034
[2] https://code.engineering.redhat.com/gerrit/150433

Comment 13 Lukas Bezdicka 2019-04-08 11:03:39 UTC
Even though this is package spec file issue we should deliver fix withing FFWD Upgrade - retargetting to OSP13.

Comment 24 errata-xmlrpc 2019-07-10 13:03:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1738


Note You need to log in before you can comment on or make changes to this bug.