Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1653762 - pod cloudforms isn't accessible if httpd service name is overridden during deployment
Summary: pod cloudforms isn't accessible if httpd service name is overridden during de...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation
Version: 5.9.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Red Hat CloudForms Documentation
QA Contact: Ievgen Zapolskyi
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 15:22 UTC by Ievgen Zapolskyi
Modified: 2019-12-19 15:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-19 15:46:55 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Ievgen Zapolskyi 2018-11-27 15:22:48 UTC
Description of problem:
Openshift template of pod cloudforms allows users to override httpd service name. 
When it is overridden during deployment, cloudforms cannot be open thru route. 
It happens because httpd pod selector in hard coded in template in both HTTPD SERVICE and HTTPD DBUS API SERVICE.

Version-Release number of selected component (if applicable):
5.9.6.2

How reproducible:
100 %

Steps to Reproduce:
1. Override httpd service name during cloudforms deployment. F.e.
oc new-app --template=cfme-template -p HTTPD_SERVICE_NAME=myhttpd
2. Open cloudforms using its url when cloudforms is eventually deployed

Actual results:
Cloudforms wasn't open because httpd service couldn't find any matching pod

Expected results:
Both HTTPD Services should have correct pod selectors

Comment 2 Ievgen Zapolskyi 2018-12-03 10:36:30 UTC
same thing when memcached service name is changed.


Note You need to log in before you can comment on or make changes to this bug.