Bug 1653812 - ansible tower items are not listed when part of service bundles
Summary: ansible tower items are not listed when part of service bundles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.5
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.10.0
Assignee: Tina Fitzgerald
QA Contact: Nandini Chandra
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks: 1656168 1660600
TreeView+ depends on / blocked
 
Reported: 2018-11-27 16:49 UTC by Felix Dewaleyne
Modified: 2019-02-12 16:50 UTC (History)
14 users (show)

Fixed In Version: 5.10.0.28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1656168 1660600 (view as bug list)
Environment:
Last Closed: 2019-02-12 16:50:55 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1652883 None NEW ancestry not set for ansible items part of a service bundle 2019-04-10 14:54:08 UTC
Red Hat Bugzilla 1654165 None CLOSED Service not showing VMs belong to 2019-04-10 14:54:08 UTC

Description Felix Dewaleyne 2018-11-27 16:49:59 UTC
Description of problem:
ansible tower items are not listed when part of service bundles

Version-Release number of selected component (if applicable):
5.9.5.3

How reproducible:
all the time

Steps to Reproduce:
1.create a bundle with an AWS orchestration and one or more ansible tower items
2.provision
3.check Services/ My Services/Active services

Actual results:
the vms provisioned from the ansible tower items are not listed

Expected results:
there is mention of what was provisioned from ansible tower items.

Additional info:
using a query such as https://my.cloudforms.example.com/api/services/54000000004933?expand=vms

will only show the aws vm and not the ansible tower items.

this seems related to bz#1652883

Comment 4 Tina Fitzgerald 2018-12-04 16:04:42 UTC
Moving to POST since the following PRs resolve this issue:

https://github.com/ManageIQ/manageiq/pull/18251
https://github.com/ManageIQ/manageiq/pull/18252

Comment 9 Tina Fitzgerald 2018-12-17 20:21:55 UTC
Adding 5.8.z flag per conversation with Dennis.

Comment 11 Nandini Chandra 2018-12-21 23:13:51 UTC
This issue is not specific to Ansible .

Steps to reproduce:
1)Create a service bundle b1 with two service items that create VMs
2)Create a service bundle b2 with two service items that create VMs
3)Create a bundle b3 with the bundles created in steps 1 and 2.

Order bundle b3.

Before fix:
Bundle b3 would only list whatever VMs were created through the first service that got ordered

After fix:
Bundle b3 lists all the VMs that were created through all its services

Comment 12 Nandini Chandra 2018-12-21 23:14:15 UTC
Verified in 5.10.0.30


Note You need to log in before you can comment on or make changes to this bug.