Bug 1653831 - repos use failovermethod option which is not supported by dnf anymore
Summary: repos use failovermethod option which is not supported by dnf anymore
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-repos
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohan Boddu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1663623 1671954 1679237 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 17:35 UTC by Flo H.
Modified: 2021-07-03 06:05 UTC (History)
31 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-11 07:25:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Flo H. 2018-11-27 17:35:19 UTC
Description of problem:

Unknown configuration value: failovermethod=priority in /etc/yum.repos.d/fedora-*.repo; Configuration: OptionBinding with id "failovermethod" does not exist

Version-Release number of selected component (if applicable):
DNF version: 4.0.9

How reproducible:
100%

Steps to Reproduce:
1. dnf -v update
2. see output
3.

Actual results:
Unknown configuration value:

Expected results:
remove failovermethod from F29 on

Additional info:

Comment 2 Kevin Fenzi 2018-11-28 18:08:34 UTC
So, lets find out if this is intended or a bug before we remove them from fedora-repos. ;) 

This was a thing brought in by yum compatibility. From the yum.conf man page:

"              failovermethod Either `roundrobin' or `priority'.

              `roundrobin' randomly selects a URL out of the list of URLs to start with and proceeds through each of
              them as it encounters a failure contacting the host.

              `priority' starts from the first baseurl listed and reads through them sequentially.

              failovermethod defaults to `roundrobin' if not specified.
"

For fedora repos at least, it would be ideal if the default behavior was just priority and there wasn't a roundrobin option, but users may have other use cases. 

Moving over to dnf folks for comment...

Comment 3 Flo H. 2018-11-28 18:51:56 UTC
FYI, dnf 4.0.4 does not show this behavior, only dnf 4.0.9 introduced this warning.
couldn't find anything related to failovermethod in the changelog: https://github.com/rpm-software-management/dnf/commit/689a4c515738226f3dc85edb2035d23233ff41d8

Comment 4 Kevin Fenzi 2019-01-05 17:33:29 UTC
*** Bug 1663623 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Fenzi 2019-02-04 16:30:42 UTC
*** Bug 1671954 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Mach 2019-02-15 14:50:42 UTC
I believe the new warning is result of fixing reporting invalid options.
The option is not used anywhere in libdnf or dnf.
You should remove it from the repo files.

Comment 7 Marek Blaha 2019-02-22 06:26:31 UTC
*** Bug 1679237 has been marked as a duplicate of this bug. ***

Comment 8 Evan Klitzke 2019-03-11 19:11:20 UTC
Ack that this is happening on a brand new F29 install. It seems harmless, but these warning messages are all over my dnf.log which makes sifting through it kind of annoying.

Comment 9 Filip Valder 2019-03-14 10:55:04 UTC
I can confirm this bug appears when building fedora:29 Docker image,

see https://rcm-tools-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/Factory%202.0/job/freshmaker-build/250/console .

Comment 10 Kevin Fenzi 2019-05-11 21:52:42 UTC
This is fixed in rawhide a long while ago... should go to other releases as we update them.

Comment 11 Phil V 2019-08-15 08:13:31 UTC
So will dnf only implement the yum option 
fallovermethod=priority ? 

or will dnf only implement the yum option
fallovermethod=roundrobin ?

Whether the url list is tried in order or random sequence should be documented in the man page.

Comment 12 Adam Salisbury 2019-11-11 11:47:10 UTC
This is happening to me in Fedora 31

Comment 13 RobbieTheK 2021-05-03 18:13:40 UTC
Fedora 34 upgrade gets this:

dnf system-upgrade download --refresh --releasever=34 --best --allowerasing
Invalid configuration value: failovermethod=roundrobin in /etc/yum.repos.d/livna.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=roundrobin in /etc/yum.repos.d/livna.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=roundrobin in /etc/yum.repos.d/livna.repo; Configuration: OptionBinding with id "failovermethod" does not exist

Comment 14 Edgar Hoch 2021-05-03 18:30:23 UTC
(In reply to RobbieTheK from comment #13)

The livna repositories are old and not supported (if I understand it correctly) – see http://rpm.livna.org/ .
I recommend to remove (delete) the livna repo files.
If neccessary, add rpmfusion repositories to your system.

It is not a bug of Fedora 34.

Comment 15 lutingrong 2021-05-14 06:27:38 UTC
this issue persists with latest fedora 33.


uname -a
Linux HP14.localdomain 5.11.19-200.fc33.x86_64 #1 SMP Fri May 7 14:10:27 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

dnf --version 
4.7.0
  Installed: dnf-0:4.7.0-1.fc33.noarch at Tue 11 May 2021 02:15:10 PM GMT
  Built    : Fedora Project at Thu 15 Apr 2021 03:03:57 PM GMT

  Installed: rpm-0:4.16.1.3-1.fc33.x86_64 at Wed 31 Mar 2021 07:51:41 AM GMT
  Built    : Fedora Project at Mon 22 Mar 2021 11:27:58 AM GMT

sudo dnf update
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-fedora-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-fedora-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-fedora-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist

Comment 16 lutingrong 2021-05-14 06:31:55 UTC
(In reply to lutingrong from comment #15)
> this issue persists with latest fedora 33.
> 
> 
> uname -a
> Linux HP14.localdomain 5.11.19-200.fc33.x86_64 #1 SMP Fri May 7 14:10:27 UTC
> 2021 x86_64 x86_64 x86_64 GNU/Linux
> 
> dnf --version 
> 4.7.0
>   Installed: dnf-0:4.7.0-1.fc33.noarch at Tue 11 May 2021 02:15:10 PM GMT
>   Built    : Fedora Project at Thu 15 Apr 2021 03:03:57 PM GMT
> 
>   Installed: rpm-0:4.16.1.3-1.fc33.x86_64 at Wed 31 Mar 2021 07:51:41 AM GMT
>   Built    : Fedora Project at Mon 22 Mar 2021 11:27:58 AM GMT
> 
> sudo dnf update
> Invalid configuration value: failovermethod=priority in
> /etc/yum.repos.d/pgdg-fedora-all.repo; Configuration: OptionBinding with id
> "failovermethod" does not exist
> Invalid configuration value: failovermethod=priority in
> /etc/yum.repos.d/pgdg-fedora-all.repo; Configuration: OptionBinding with id
> "failovermethod" does not exist
> Invalid configuration value: failovermethod=priority in
> /etc/yum.repos.d/pgdg-fedora-all.repo; Configuration: OptionBinding with id
> "failovermethod" does not exist

am I supposed to modify pgdg-fedora-all.repo?

Comment 17 Peter Robinson 2021-05-14 06:40:54 UTC
> am I supposed to modify pgdg-fedora-all.repo?

Yes, or who ever maintains it should

Comment 18 Jan "Yenya" Kasprzak 2021-06-11 07:22:59 UTC
I see this since Fedora 34 upgrade as well. This bug has been CLOSED RAWHIDE in 2019, so I guess it either did not get fixed, or the Fedora 34 problem is a different one. I am reopening this.

Comment 19 Peter Robinson 2021-06-11 07:25:53 UTC
(In reply to Jan "Yenya" Kasprzak from comment #18)
> I see this since Fedora 34 upgrade as well. This bug has been CLOSED RAWHIDE
> in 2019, so I guess it either did not get fixed, or the Fedora 34 problem is
> a different one. I am reopening this.

It's fixed in Fedora, if there's 3rd party repos that haven't updated it's not something that Fedora can fix and you should report bugs to them.

Comment 20 Jan "Yenya" Kasprzak 2021-06-11 07:32:59 UTC
I see this only for fedora.repo and fedora-updates.repo. But nevertheless, I have missed the .rpmnew versions of these files from April 2020. Sorry for the noise.

Comment 21 Alyssa Coghlan 2021-07-03 06:05:04 UTC
It's not clear to me from the comments here or the existing documentation what DNF's behaviour actually *is* when multiple URLs are given in baseurl.

From experience, it *seems* to be equivalent to yum's failovermethod=priority, so I submitted a DNF baseurl docs PR to that effect: https://github.com/rpm-software-management/dnf/pull/1783


Note You need to log in before you can comment on or make changes to this bug.