Bug 165411 - system-config-packages erroneously claims "Packages Not Found"
system-config-packages erroneously claims "Packages Not Found"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 22:53 EDT by Keith Hanlan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from the system-config-packages --isodir command (7.47 KB, text/plain)
2005-08-08 22:56 EDT, Keith Hanlan
no flags Details

  None (edit)
Description Keith Hanlan 2005-08-08 22:53:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050717

Description of problem:
I have my four FC4 CDROM images sitting in a directory:
   /Backup/FC4/FC4-i386-disc1.iso 
   /Backup/FC4/FC4-i386-disc2.iso 
   /Backup/FC4/FC4-i386-disc3.iso 
   /Backup/FC4/FC4-i386-disc4.iso 
   /Backup/FC4/FC4-i386-rescuecd.iso

When I run the command:
    # system-config-packages --isodir=/Backup/FC4
the "Package Management" GUI pops up as it should.

At this point, if I do a "df -a", I see that only one of the ISO images is mounted. [It should be all four should it not?]

Now, when I select Development->Java Development and click "Update", I get the following error message:
         "Packages Not Found
          The following packages could not be found on your system.
          Installation cannot continue until they are installed."
And the output box displays:
    Unlocatable package             Required by
    -------------------             -----------
    gcc                             ('gcc-gfortran','4.0.1',4.fc4)
    gcc                             ('libtool','1.5.16.multilib2','2')
    gcc                             ('gcc-c++','4.0.1','4.fc4')

The console output from the command adds the following similar text:
   * using tomcat5-servlet-2.4-api-0:5.0.30-5jpp_6fc.i386 to satisfy servletapi5
   * using gcc-0:4.0.0-8.i386 to satisfy gcc-4.0.0-8
   * using cpp-0:4.0.0-8.i386 to satisfy cpp-4.0.0-8
   ('gcc', '4.0.1-4.fc4')
   ('gcc', '4.0.1')
   ('gcc', '4.0.1-4.fc4')

The Java Development packages were not originally installed so the selection changed the package list from [0/122] to [122/122].
Note that I have already run up2date and so gcc-4.0.1 is installed:
   root@kph [139]* rpm -qf /usr/bin/gcc
   gcc-4.0.1-4.fc4

I have tried forcibly reinstalling gcc using the --replacepkgs option and I have also rebuilt the RPM database using --rebuilddb. Neither has helped.

Version-Release number of selected component (if applicable):
system-config-packages-1.2.25-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 without "Java Development" packages.
2. Use "up2date"
3. Run system-config-packages --isodir=...
4. Select "Java Development" packages
5. Click "Update"
  

Actual Results:  The dependency checks messed up as described above.

Expected Results:  It should have installed the 122 Java Development packages in ISODIR or their updated packages.

Additional info:

It is a "Normal" bug but still fairly serious because I can't update my system. If it was just one or two packages, I'd install them by hand but the list is 122 and that's just unmanagable.

A related issue is that I can't use the --tree=<path> option either because it complains:
   "Installation Tree Not Found.
    The path /Backup/FC4 does not look
    like a valid installation source."

This is despite the fact that I've created the Fedora directory with RPMS and base subdirectories as described in the distribution README file:
   |root@kph [185]* ll /Backup/FC4 /Backup/FC4/Fedora
   |/Backup/FC4:
   |total 2690092
   |-rw-rw-r--  1 keithh keithh 665434112 Jun 14 20:51 FC4-i386-disc1.iso
   |-rw-rw-r--  1 keithh keithh 668708864 Jun 14 20:51 FC4-i386-disc2.iso
   |-rw-rw-r--  1 keithh keithh 668954624 Jun 14 20:51 FC4-i386-disc3.iso
   |-rw-rw-r--  1 keithh keithh 660512768 Jun 14 20:51 FC4-i386-disc4.iso
   |-rw-rw-r--  1 keithh keithh  88256512 Jun 14 20:51 FC4-i386-rescuecd.iso
   |drwxr-xr-x  4 root   root        4096 Jun  6 22:45 Fedora/
   |-rw-r--r--  1 root   root       51265 Jun  6 22:25 RELEASE-NOTES
   |-rw-rw-r--  1 keithh keithh       871 Jun 14 20:51 SHA1SUM
   |
   |/Backup/FC4/Fedora:
   |total 84
   |drwxr-xr-x  2 root root 73728 Jul 25 22:54 RPMS/
   |-r--r--r--  1 root root   216 Jun  6 22:56 TRANS.TBL
   |drwxr-xr-x  2 root root  4096 Jun  6 22:54 base/

and all 1808 packages are in the RPMS directory:
   |root@kph [186]* ls /Backup/FC4/Fedora/RPMS | wc -l
   |1808

I'm going to see if I can do an end-run around the problem by converting my 4 CDROM images into a single DVD image. Perhaps that will avoid the first problem.

Finally, I wish the system-config-X routines had documentation and --verbose or --debug options.
Comment 1 Keith Hanlan 2005-08-08 22:56:04 EDT
Created attachment 117564 [details]
Output from the system-config-packages --isodir command

This is simply the console output that appears when I run the command with the
--isodir option.
Comment 2 Keith Hanlan 2005-08-08 23:00:10 EDT
This might be two separate issues. As near as I can tell, neither of them match
any of the currently listed FC4 bugs against this application.
Comment 3 Keith Hanlan 2005-08-09 06:20:27 EDT
Some further investigation has shown that it is in fact two separate issues. The
second point regarding the "Installation Tree Not Found." message is solved by
copying the .discinfo file from the first CDROM. However, once one is past this
matter, the first issue remains, regardless of whether one uses --isodir or -tree.

I have modified the summary to reflect this and will open another bug to address
the undocumented and unnecessary requirement for .discinfo.
Comment 4 Jeremy Katz 2005-09-21 16:03:14 EDT
This will be resovled in the next generation tool to be found in FC5

Note You need to log in before you can comment on or make changes to this bug.