Bug 1654126 - The 'dbus-python' distribution was not found and is required by subscription-manager
Summary: The 'dbus-python' distribution was not found and is required by subscription-...
Keywords:
Status: CLOSED DUPLICATE of bug 1651669
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: subscription-manager
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 05:56 UTC by Han Han
Modified: 2018-12-10 15:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-10 15:48:32 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1654774 'unspecified' 'CLOSED' 'dbus-python does not provide egg metadata in RPM' 2019-11-13 19:59:05 UTC

Internal Links: 1654774

Description Han Han 2018-11-28 05:56:21 UTC
Description of problem:
As subject

Version-Release number of selected component (if applicable):
subscription-manager-1.23.8-2.el8.x86_64
platform-python-3.6.7-3.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. /usr/libexec/rhsmcertd-worker        
Traceback (most recent call last):
  File "/usr/libexec/rhsmcertd-worker", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3095, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3079, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 570, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 888, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 774, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'dbus-python' distribution was not found and is required by subscription-manager

Actual results:
As above

Expected results:
no error

Additional info:
dbus-python is not contained in rhel8. Please check pkg python3-dbus instead.

Comment 2 Chris Snyder 2018-12-10 15:48:32 UTC

*** This bug has been marked as a duplicate of bug 1651669 ***


Note You need to log in before you can comment on or make changes to this bug.