Bug 165415 - anaconda dies after asking about the ethernet interfaces
Summary: anaconda dies after asking about the ethernet interfaces
Status: CLOSED DUPLICATE of bug 163722
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-09 05:24 UTC by Keith Matthews
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-12 15:50:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Keith Matthews 2005-08-09 05:24:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Firefox/1.0.6 (Debian package 1.0.6-1)

Description of problem:
Attempting to install RHEL4-U2-re0721.0-ppc onto an IBM p5 Model 570, into an LPAR with Only 2 * Virtual Ethernets and 1 * Virtual SCSI Client Adapter (10G Virtual Drive from IBM Virtual I/O server 1.1.

I have check the CD's they are ok

Anaconda Output is as follows.
An unhandled exception has occurred.  This   # |
               | is most likely a bug.  Please copy the       # |
               | full text of this exception and file a       # |
               | detailed bug report against anaconda at      # |
               | http://bugzilla.redhat.com/bugzilla/         # |
               |                                              # |
               | Traceback (most recent call last):           # |
               |   File "/usr/bin/anaconda", line 1173, in ?  # |
               |     intf.run(id, dispatch, configFileData)   # |
               |   File                                       # |
               | "/usr/src/build/591232-ppc/install//usr/lib  # |
               | /anaconda/text.py", line 487, in run         #
               |     rc = apply(win, (self.screen, ) + args)  # |
               | TypeError: __call__() takes exactly 5        # |
               | arguments (6 given)                          # |

I took the Dafult Options on Install for Disk Partitioning an empty /dev/sda (AutoPartition) and Default options for eth0 & eth1. anaconda then crashes with above error.





Version-Release number of selected component (if applicable):
RHEL4-U2-re0721.0-ppc

How reproducible:
Always

Steps to Reproduce:
1.Start install
2.Choose Default Options
3.Get as far as completeing the ethernet config.
  

Actual Results:  Errors above

Expected Results:  Well one would hope to continue the install I guess 8-)

Additional info:

I am the IBM LTC in Australia. I obtained the disk images from our ftp3 server to install for out kernel developers to test some stuff.

Comment 1 Jeremy Katz 2005-08-09 14:25:40 UTC
Please provide the complete traceback you received.

Also, note that you're probably supposed to be filing this via IssueTracker instead.

Comment 2 Keith Matthews 2005-08-10 01:28:37 UTC
Hi,

Sorry but that is all the traceback I recieved. 

I scrolled down and it ended with the "arguments (6 given)" Line. I thought it
looked like there should be more, but I have just checked again, and thats where
the traceback stops.

IssueTracker?

Would you like me to re-enter it there?

I just followed the link in the traceback 8-)



Comment 3 Paul Nasrat 2005-08-12 15:50:57 UTC
That's a really old tree this got fixed on the 22 July in anaconda 10.1.1.22-1

*** This bug has been marked as a duplicate of 163722 ***

Comment 4 Paul Nasrat 2005-08-12 15:56:31 UTC
Also note using a vnc install at yaboot prompt:

linux vnc

Will install without the exception.


Note You need to log in before you can comment on or make changes to this bug.