Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1654209 - [Both slow train and upstream fast train] {"error": {"class": "GenericError", "desc": "failed to open /mnt: Permission denied"}} when 'guest-fsfreeze-freeze' with mounted none system disk in the guest
Summary: [Both slow train and upstream fast train] {"error": {"class": "GenericError",...
Keywords:
Status: CLOSED DUPLICATE of bug 1607685
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: qemu-kvm
Version: 8.0
Hardware: ppc64le
OS: Unspecified
high
high
Target Milestone: rc
: 8.0
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 09:19 UTC by Gu Nini
Modified: 2019-02-22 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-28 09:58:50 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Gu Nini 2018-11-28 09:19:02 UTC
Description of problem:
Both up guest with a data disk; mkfs/mount the disk inside the guest; when issue the guest agent cmd 'guest-fsfreeze-freeze', it returns error:

{"error": {"class": "GenericError", "desc": "failed to open /mnt: Permission denied"}}

If not mount the disk inside the guest, there is no problem to do 'guest-fsfreeze-freeze'.


Version-Release number of selected component (if applicable):
Host kernel: 4.18.0-40.el8.ppc64le
Slow train qemu: qemu-kvm-2.12.0-44.module+el8+2259+6d80f0a6.ppc64le
Upstream fast train qemu: v3.1.0-rc2-20-g5298f4d67a-dirty (Till commit 5298f4d67a911dd9cefa4c4185eed242074d64c2)

How reproducible:
100%

Steps to Reproduce:
1. Boot up a rhel8.0 guest with a data disk.

    -blockdev driver=file,filename=/home/ngu/rhel80-ppc64le-upstream.qcow2,node-name=file0 \
    -blockdev driver=qcow2,file=file0,node-name=disk0 \
    -device scsi-hd,drive=disk0,id=image0,bootindex=0 \
    -blockdev driver=file,filename=/home/ngu/hd1.qcow2,node-name=file1 \
    -blockdev driver=qcow2,file=file1,node-name=ddisk0 \
    -device scsi-hd,drive=ddisk0,id=image1,bootindex=1 \

2. Install and start the guest agent service inside the guest.
3. mkfs/mount the data disk inside the guest:
# mkfs.ext4 /dev/sdb
# mount /dev/sdb /mnt

4. Try to 'guest-fsfreeze-freeze' the guest file system:
{"execute":"guest-fsfreeze-freeze"}


Actual results:
Failed to freeze the guest file system with following error:

{"error": {"class": "GenericError", "desc": "failed to open /mnt: Permission denied"}}


Expected results:
It's a success to freeze the guest file system that mounted


Additional info:
1. Not sure if the bug is ppc only currently, will try it on x86.
2. The x86 feature owner(xfu) wonder this is the same issue as bz1584318 on RHEL7.

Comment 1 Gu Nini 2018-11-28 09:58:50 UTC

*** This bug has been marked as a duplicate of bug 1607685 ***


Note You need to log in before you can comment on or make changes to this bug.