Bug 1654241 - Add backend functionality to UI's Server Tab No. 2 (CLI and UI)
Summary: Add backend functionality to UI's Server Tab No. 2 (CLI and UI)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: DS11.0
: dirsrv-11.0
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard: sync-to-jira
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 10:20 UTC by Anuj Borah
Modified: 2019-11-06 12:42 UTC (History)
10 users (show)

Fixed In Version: 389-ds-base-1.4.1.6-2.module+el8dsrv+3912+aa2ce078.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 12:42:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
SS for passwordstoragescheme (103.98 KB, image/png)
2018-11-28 10:29 UTC, Anuj Borah
no flags Details
button 1 (130.57 KB, image/png)
2018-11-28 11:37 UTC, Anuj Borah
no flags Details
button 2 (131.02 KB, image/png)
2018-11-28 11:37 UTC, Anuj Borah
no flags Details
junk (127.31 KB, image/png)
2018-11-28 15:56 UTC, Anuj Borah
no flags Details
empty (127.31 KB, image/png)
2018-11-28 15:57 UTC, Anuj Borah
no flags Details
empty value (128.03 KB, image/png)
2018-11-28 16:00 UTC, Anuj Borah
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3731 None None None 2019-11-06 12:42:24 UTC

Description Anuj Borah 2018-11-28 10:20:06 UTC
Description of problem:

Add backend functionality to UI's Server Tab No. 2 (CLI and UI)

Version-Release number of selected component (if applicable):

389-ds-base-1.4.0

Comment 1 Anuj Borah 2018-11-28 10:28:39 UTC
Description of problem:

Failed to update attribute: passwordstoragescheme


Open cockpit for RHDS.
https://rhds-ip-address:9090 >
389 Directory Server > Server Settings > Password Policy > Global Password Policy > Password Storage Scheme > NS-MTA-MD5 >  Failed to update attribute: passwordstoragescheme


Version-Release number of selected component (if applicable):
RHDS 11

How reproducible:
Always

Steps to Reproduce:
1. Mentioned above
2.
3.

Actual results:

Failed to update attribute: passwordstoragescheme And server hangs .


Expected results:

Should take the value .


Additional info:

Comment 2 Anuj Borah 2018-11-28 10:29:23 UTC
Created attachment 1509441 [details]
SS for passwordstoragescheme

Comment 3 Anuj Borah 2018-11-28 11:36:24 UTC
Description of problem:

Enable Audit Failure Logging  button is not working as expected


Open cockpit for RHDS.
389 Directory Server > Server Settings > Audit Failure Log Settings .
"Enable Audit Failure Logging"  button is not working as expected .

If you click on "Enable Audit Failure Logging"  button , whether it is ticked or not , user can edit 

Rotation Policy and Deletion Policy.



Version-Release number of selected component (if applicable):
RHDS 11

How reproducible:
Always

Steps to Reproduce:
1. Mentioned above
2.
3.

Actual results:

Enable Audit Failure Logging  button is not working as expected


Expected results:

It should work as expected.

Additional info:

Comment 4 Anuj Borah 2018-11-28 11:37:16 UTC
Created attachment 1509452 [details]
button 1

Comment 5 Anuj Borah 2018-11-28 11:37:48 UTC
Created attachment 1509454 [details]
button 2

Comment 6 Anuj Borah 2018-11-28 15:55:20 UTC
Description of problem:

"Map System User to Database Entry" accepting empty and junk values as input .


Open cockpit for RHDS.
389 Directory Server > Server Settings > LDAPI & Autobind Settings > Map System User to Database Entry

"Map System User to Database Entry" accepting empty and junk values as input .



Version-Release number of selected component (if applicable):
RHDS 11

How reproducible:
Always

Steps to Reproduce:
1. Mentioned above
2.
3.

Actual results:

Enable Audit Failure Logging  button is not working as expected


Expected results:

It should work as expected.

Additional info:

Comment 7 Anuj Borah 2018-11-28 15:56:21 UTC
Created attachment 1509552 [details]
junk

Comment 8 Anuj Borah 2018-11-28 15:57:27 UTC
Created attachment 1509553 [details]
empty

Comment 9 Anuj Borah 2018-11-28 16:00:43 UTC
Created attachment 1509555 [details]
empty value

Comment 16 Viktor Ashirov 2019-09-30 07:45:24 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

Backend functionality was added to the tab.
Issue from comments #1, #3, #6 are fixed.

Marking as VERIFIED.

Comment 18 errata-xmlrpc 2019-11-06 12:42:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3731


Note You need to log in before you can comment on or make changes to this bug.