Bug 1654248 - /etc/login.defs trailing space
Summary: /etc/login.defs trailing space
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: shadow-utils
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: Tomas Mraz
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks: 1623566 1647562
TreeView+ depends on / blocked
 
Reported: 2018-11-28 10:23 UTC by Markus Schibli
Modified: 2019-06-14 01:18 UTC (History)
3 users (show)

Fixed In Version: shadow-utils-4.6-6.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:18:39 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 3720891 None None None 2018-11-30 13:45:33 UTC

Internal Links: 1647562

Description Markus Schibli 2018-11-28 10:23:10 UTC
Description of problem:
The file /etc/login.defs is causing to pop up as difference on customer's systems because of the last line of the file which is "ENCRYPT_METHOD SHA512 " and contains a trailing space. 

Version-Release number of selected component (if applicable):
# rpm -qf /etc/login.defs
shadow-utils-4.6-4.el8.x86_64

How reproducible:
# grep  ' $' /etc/login.defs
# The permission mask is initialized to this value. If not specified, 
ENCRYPT_METHOD SHA512 

Actual results:
Trailing space at the end of ENCRYPT_METHOD SHA512 in /etc/login.defs

Expected results:
no trailling space at the end of the line ENCRYPT_METHOD SHA512 in /etc/login.defs

Additional info:


Note You need to log in before you can comment on or make changes to this bug.