Bug 1654270 - glusterd crashed with seg fault possibly during node reboot while volume creates and deletes were happening
Summary: glusterd crashed with seg fault possibly during node reboot while volume crea...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On: 1654161
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 11:23 UTC by Sanju
Modified: 2020-01-09 17:25 UTC (History)
9 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1654161
Environment:
Last Closed: 2019-02-19 09:28:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21743 0 None Merged glusterd: perform rcu_read_lock/unlock() under cleanup_lock mutex 2018-12-03 17:04:38 UTC
Gluster.org Gerrit 21974 0 None Merged glusterd: kill the process without releasing the cleanup mutex lock 2019-01-02 11:28:11 UTC
Gluster.org Gerrit 22146 0 None Merged glusterd: adding a comment for code readability 2019-02-19 09:28:51 UTC

Comment 1 Worker Ant 2018-11-28 11:26:16 UTC
REVIEW: https://review.gluster.org/21743 (glusterd: don't acquire locks on resources when cleanup is already started) posted (#1) for review on master by Sanju Rakonde

Comment 2 Worker Ant 2018-12-03 17:04:35 UTC
REVIEW: https://review.gluster.org/21743 (glusterd: perform rcu_read_lock/unlock() under cleanup_lock mutex) posted (#5) for review on master by Atin Mukherjee

Comment 3 Worker Ant 2019-01-02 07:29:02 UTC
REVIEW: https://review.gluster.org/21974 (glusterd: kill the process without releasing the cleanup mutex lock) posted (#1) for review on master by Sanju Rakonde

Comment 4 Worker Ant 2019-01-02 11:28:10 UTC
REVIEW: https://review.gluster.org/21974 (glusterd: kill the process without releasing the cleanup mutex lock) posted (#1) for review on master by Sanju Rakonde

Comment 5 Worker Ant 2019-02-19 09:28:52 UTC
REVIEW: https://review.gluster.org/22146 (glusterd: adding a comment for code readability) merged (#5) on master by Atin Mukherjee

Comment 6 Shyamsundar 2019-03-25 16:32:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.