Bug 1654322 - Adding parameters to "/etc/default/grub" and rebuilding grub will not work.
Summary: Adding parameters to "/etc/default/grub" and rebuilding grub will not work.
Keywords:
Status: CLOSED DUPLICATE of bug 1651686
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: grub2
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Bootloader engineering team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 14:20 UTC by Ishan Kulkarni
Modified: 2018-11-28 14:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-28 14:30:12 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Ishan Kulkarni 2018-11-28 14:20:58 UTC
Description of problem:

If kernel command line parameters are added to "/etc/default/grub" and if the grub is rebuilt using grub2-mkconfig -o /boot/grub2/grub.cfg, it will never come into effect and will always fail.


Version-Release number of selected component (if applicable):

Observed on     :  RHEL 8.0 beta
Kernel version  :  4.18.0-32.el8.x86_64
Grub2 version   :  grub2-pc-2.02-57.el8.x86_64


How reproducible:

This issue can always be reproduced with 100% success rate.

Steps to Reproduce:
1. Fresh install RHEL 8 beta
2. Once the installation gets complete, edit "/etc/default/grub" and add kernel commandline parameters at "GRUB_CMDLINE_LINUX" line.
3. Rebuild the grub using grub2-mkconfig -o /boot/grub2/grub.cfg
4. Reboot the server and test.


Actual results:

The added parameters will never come into effect and the addition of parameters will always fail.


Expected results:

Added kernel command line parameters should work and they should come into effect.


Additional info:

Comment 1 Javier Martinez Canillas 2018-11-28 14:30:12 UTC

*** This bug has been marked as a duplicate of bug 1651686 ***


Note You need to log in before you can comment on or make changes to this bug.