Bug 165437 - control-z to access the ash shell no longer functions
control-z to access the ash shell no longer functions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 07:12 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 11:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2005-08-09 07:12:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050730 Fedora/1.7.11-1

Description of problem:
Since bugzilla is a nightmare to navigate both for the sited and those without site, this bug is being filed to make this bug submittable.
From the communications relating to the problem. This excerpt from the email to explain the problem.

---
I (and several others) have been using telnet to install FC4. Very nice.

However, there's one capibility that used to be there which is no longer
there in the newly fixed telnet feature.

In the old days (up until FC2), we could use ctrl-z to suspend telnet
and access an ash shell. This no longer works.

The ctrl-z suspend was particularly valuable for tweaks to the newly
installed system before a reboot, especially for "eyes-free" users who
are not being served by First Boot (and our inability to escape out of
First Boot). I guess our "first boot" was the ctrl-z suspend
functionality!



Version-Release number of selected component (if applicable):
telnet-0.17-35

How reproducible:
Always

Steps to Reproduce:
1. press ctl-z
2. wait for suspend to ash
3. experience no suspend to ash
  

Actual Results:  cannot access ash shell to tweak parameters for system before boot is complete. 

Expected Results:  pressing ctl-z should allow escape from firstboot to tweak system to desired settings before firstboot goes further and errors because parameters are not set.

Additional info:

Bugzilla should work better for text browsers.
Comment 1 Jim Cornette 2005-08-09 07:16:38 EDT
Added Janina and William to cc for further specifics to bug report.
Comment 2 Janina Sajka 2005-08-09 13:14:53 EDT
To clarify, this is not a bug against firstboot, but against functionality of a telnet installation
Once an installation of Fedora over telnet completes, and the "congratulations, Installation complete" screen appears with its <reboot> button,
it used to be possible to issue Ctrl-Z and access an ash shell prompt, whereupon we could cd to /mnt/sysimage,
chroot . and perform important tasks such as:

"/sbin/chkconfig --level 0123456 firstboot off" plus other tasks
This is no longer the case. Ctrl-Z simply doesn't suspend telnet and execute a sub shell.

I suppose the inescapibility of firstboot should be a separate issue?
Comment 3 Harald Hoyer 2005-08-23 06:00:23 EDT
this is not a problem of telnet client... this is a problem on the server side
Comment 4 Jeremy Katz 2005-08-23 11:04:02 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.