Bug 1654410 - Glance image conversion fails
Summary: Glance image conversion fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 14.0 (Rocky)
Assignee: Abhishek Kekane
QA Contact: Mike Abrams
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 17:34 UTC by Gregory Charot
Modified: 2019-03-18 12:53 UTC (History)
6 users (show)

Fixed In Version: openstack-glance-17.0.1-0.20190109153320.f3a584f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 12:53:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0583 None None None 2019-03-18 12:53:41 UTC

Description Gregory Charot 2018-11-28 17:34:41 UTC
Description of problem:

It is not possible to convert glance images

Version-Release number of selected component (if applicable):

14

How reproducible:

Always

Steps to Reproduce:
1. glance image-create-via-import --disk-format qcow2 --container-format bare --name cirros --import-method web-download --uri http://download.cirros-cloud.net/0.4.0/cirros-0.4.0-x86_64-disk.img

2.
3.

Actual results:

Image is not converted (stays in qcow), Glance api logs:

2018-11-28 16:26:46.502 24 INFO eventlet.wsgi.server [-] 172.17.1.201 - - [28/Nov/2018 16:26:46] "GET /healthcheck HTTP/1.0" 200 137 0.003688
2018-11-28 16:26:46.870 25 WARNING glance.async.taskflow_executor [-] Task 'api_image_import-Convert_Image-f8822a30-4980-451d-bbed-d73fd48736a8' (ba9729e1-9069-40fd-a3fd-496072765936) transitioned into state 'FAILURE' from state 'RUNNING'
5 predecessors (most recent first):
  Flow 'api_image_import'
  |__Atom 'api_image_import-ConfigureStaging-f8822a30-4980-451d-bbed-d73fd48736a8' {'intention': 'EXECUTE', 'state': 'SUCCESS', 'requires': {}, 'provides': 'file:///var/lib/glance/staging/7b317981-81a6-4839-8bc3-a138ddb4472d'}
     |__Flow 'api_image_import'
        |__Atom 'api_image_import_retry' {'intention': 'EXECUTE', 'state': 'SUCCESS', 'requires': {}, 'provides': [(None, {})]}
           |__Flow 'api_image_import': NoSuchOptError: no such option conversion_plugin_options in group [DEFAULT]
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor Traceback (most recent call last):
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor   File "/usr/lib/python2.7/site-packages/taskflow/engines/action_engine/executor.py", line 53, in _execute_task
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor     result = task.execute(**arguments)
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor   File "/usr/lib/python2.7/site-packages/glance/async/flows/plugins/image_conversion.py", line 78, in execute
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor     target_format = CONF.conversion_plugin_options.output_format
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2644, in __getattr__
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor     raise NoSuchOptError(name)
2018-11-28 16:26:46.870 25 ERROR glance.async.taskflow_executor NoSuchOptError: no such option conversion_plugin_options in group [DEFAULT]


Expected results:

Conversion works

Additional info:

Issue is there http://git.openstack.org/cgit/openstack/glance/tree/glance/async_/flows/plugins/image_conversion.py#n78

CONF.conversion_plugin_options.output_format looks incorrect. Worked around with
target_format = CONF.image_conversion.output_format

Comment 1 Abhishek Kekane 2018-11-29 06:17:08 UTC
Reported upstream bug;
https://bugs.launchpad.net/glance/+bug/1805765

Submitted a fix:
https://review.openstack.org/#/c/620781/

Need to backport to stable/rocky once merged in master branch.

Comment 14 errata-xmlrpc 2019-03-18 12:53:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0583


Note You need to log in before you can comment on or make changes to this bug.