Bug 1654413 - Glance image conversion is not enabled by default
Summary: Glance image conversion is not enabled by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 14.0 (Rocky)
Assignee: Pranali Deore
QA Contact: Mike Abrams
URL:
Whiteboard:
: 1673952 (view as bug list)
Depends On: 1654405
Blocks: 1654408
TreeView+ depends on / blocked
 
Reported: 2018-11-28 17:57 UTC by Gregory Charot
Modified: 2019-04-30 17:51 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-9.2.1-0.20190119154863.el7ost puppet-glance-13.3.2-0.20190111170809.2312a82.el7ost
Doc Type: Release Note
Doc Text:
Glance image conversion is not enabled by default on a new install of Red Hat OpenStack Platform 14. To use this feature, edit the glance-image-import.conf file. In the image_import_opts section, insert the following line: image_import_plugins = ['image_conversion']
Clone Of:
Environment:
Last Closed: 2019-04-30 17:51:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 623443 None None None 2018-12-07 11:14:11 UTC
OpenStack gerrit 623450 None None None 2018-12-07 11:14:48 UTC
OpenStack gerrit 624582 None None None 2018-12-13 17:56:10 UTC
OpenStack gerrit 624931 None None None 2018-12-13 17:55:37 UTC
Red Hat Product Errata RHBA-2019:0878 None None None 2019-04-30 17:51:25 UTC

Description Gregory Charot 2018-11-28 17:57:17 UTC
Description of problem:

Glance image conversion is not configured by tripleO. glance-image-import.conf must be configured

Version-Release number of selected component (if applicable):

14

How reproducible:

Always

Steps to Reproduce:
1. in glance_api container 
grep image_import_plugins /etc/glance/glance-image-import.conf
#image_import_plugins = [no_op]

2. glance image-create-via-import --disk-format qcow2 --container-format bare --name cirros --import-method web-download --uri http://download.cirros-cloud.net/0.4.0/cirros-0.4.0-x86_64-disk.img
3. Image is still in qcow2

Actual results:

Image is not converted

Expected results:

Image is converted

Additional info:

Need to have 
image_import_plugins = ['image_conversion']

in glance-image-import.conf

Comment 1 Paul Grist 2018-11-30 16:35:34 UTC
We are going to target the first erratta release for 14 to fix this and plan to release not for 14 GA.

Comment 17 Gregory Charot 2019-04-05 12:55:22 UTC
*** Bug 1673952 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2019-04-30 17:51:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0878


Note You need to log in before you can comment on or make changes to this bug.