Bug 1654441 - [3.2.0-0.1.rc4.el7cp Unexpected failure during module execution]
Summary: [3.2.0-0.1.rc4.el7cp Unexpected failure during module execution]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 3.2
Assignee: Guillaume Abrioux
QA Contact: Vasu Kulkarni
URL:
Whiteboard:
Depends On:
Blocks: 1641792
TreeView+ depends on / blocked
 
Reported: 2018-11-28 19:51 UTC by Vasu Kulkarni
Modified: 2019-01-03 19:02 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.rc6.el7cp Ubuntu: ceph-ansible_3.2.0~rc6-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3386 None None None 2018-11-29 09:38:18 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:34 UTC

Description Vasu Kulkarni 2018-11-28 19:51:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):
a) ceph 12.2.8-42.el7cp
b) ceph-ansible 3.2.0-0.1.rc4.el7cp


Steps to Reproduce:
Trying to install with above versions, 

Inventory file is https://paste.fedoraproject.org/paste/38D-tlxF7z1yQw8WJonmag/raw

Group vars: https://paste.fedoraproject.org/paste/xs2DK~aqcCzrtFjOeMl8gg/raw



Actual results:

http://magna002.ceph.redhat.com/vasu-2018-11-28_12:53:24-smoke-luminous-distro-basic-multi/314510/teuthology.log

2018-11-28T13:21:49.691 INFO:teuthology.orchestra.run.argo016.stdout:TASK [ceph-config : set_fact num_osds from the output of 'ceph-volume lvm list'] ***
2018-11-28T13:21:49.692 INFO:teuthology.orchestra.run.argo016.stdout:task path: /home/ubuntu/ceph-ansible/roles/ceph-config/tasks/main.yml:66
2018-11-28T13:21:49.692 INFO:teuthology.orchestra.run.argo016.stdout:Wednesday 28 November 2018  18:21:42 +0000 (0:00:00.158)       0:06:34.752 ****
2018-11-28T13:21:49.692 INFO:teuthology.orchestra.run.argo016.stdout:skipping: [argo019.ceph.redhat.com] => {
2018-11-28T13:21:49.692 INFO:teuthology.orchestra.run.argo016.stdout:    "changed": false,
2018-11-28T13:21:49.693 INFO:teuthology.orchestra.run.argo016.stdout:    "skip_reason": "Conditional result was False"
2018-11-28T13:21:49.693 INFO:teuthology.orchestra.run.argo016.stdout:}
2018-11-28T13:21:49.693 INFO:teuthology.orchestra.run.argo016.stdout:skipping: [argo021.ceph.redhat.com] => {
2018-11-28T13:21:49.694 INFO:teuthology.orchestra.run.argo016.stdout:    "changed": false,
2018-11-28T13:21:49.694 INFO:teuthology.orchestra.run.argo016.stdout:    "skip_reason": "Conditional result was False"
2018-11-28T13:21:49.694 INFO:teuthology.orchestra.run.argo016.stdout:}
2018-11-28T13:21:49.694 INFO:teuthology.orchestra.run.argo016.stdout:skipping: [argo031.ceph.redhat.com] => {
2018-11-28T13:21:49.695 INFO:teuthology.orchestra.run.argo016.stdout:    "changed": false,
2018-11-28T13:21:49.695 INFO:teuthology.orchestra.run.argo016.stdout:    "skip_reason": "Conditional result was False"
2018-11-28T13:21:49.695 INFO:teuthology.orchestra.run.argo016.stdout:}
2018-11-28T13:21:49.695 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.696 INFO:teuthology.orchestra.run.argo016.stdout:TASK [ceph-config : generate ceph configuration file: ceph.conf] ***************
2018-11-28T13:21:49.696 INFO:teuthology.orchestra.run.argo016.stdout:task path: /home/ubuntu/ceph-ansible/roles/ceph-config/tasks/main.yml:77
2018-11-28T13:21:49.696 INFO:teuthology.orchestra.run.argo016.stdout:Wednesday 28 November 2018  18:21:42 +0000 (0:00:00.171)       0:06:34.923 ****
2018-11-28T13:21:49.696 INFO:teuthology.orchestra.run.argo016.stdout:An exception occurred during task execution. To see the full traceback, use -vvv. The error was: 	[line 19]: u' # non_hci_safety_factor is the safety factor for dedicated nodes\n'
2018-11-28T13:21:49.697 INFO:teuthology.orchestra.run.argo016.stdout:fatal: [argo019.ceph.redhat.com]: FAILED! => {}
2018-11-28T13:21:49.697 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.697 INFO:teuthology.orchestra.run.argo016.stdout:MSG:
2018-11-28T13:21:49.697 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.698 INFO:teuthology.orchestra.run.argo016.stdout:Unexpected failure during module execution.
2018-11-28T13:21:49.698 INFO:teuthology.orchestra.run.argo016.stdout:An exception occurred during task execution. To see the full traceback, use -vvv. The error was: 	[line 16]: u' # non_hci_safety_factor is the safety factor for dedicated nodes\n'
2018-11-28T13:21:49.698 INFO:teuthology.orchestra.run.argo016.stdout:fatal: [argo021.ceph.redhat.com]: FAILED! => {}
2018-11-28T13:21:49.699 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.699 INFO:teuthology.orchestra.run.argo016.stdout:MSG:
2018-11-28T13:21:49.699 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.699 INFO:teuthology.orchestra.run.argo016.stdout:Unexpected failure during module execution.
2018-11-28T13:21:49.700 INFO:teuthology.orchestra.run.argo016.stdout:An exception occurred during task execution. To see the full traceback, use -vvv. The error was: 	[line 16]: u' # non_hci_safety_factor is the safety factor for dedicated nodes\n'
2018-11-28T13:21:49.700 INFO:teuthology.orchestra.run.argo016.stdout:fatal: [argo031.ceph.redhat.com]: FAILED! => {}
2018-11-28T13:21:49.700 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.700 INFO:teuthology.orchestra.run.argo016.stdout:MSG:
2018-11-28T13:21:49.701 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.701 INFO:teuthology.orchestra.run.argo016.stdout:Unexpected failure during module execution.
2018-11-28T13:21:49.701 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.701 INFO:teuthology.orchestra.run.argo016.stdout:PLAY RECAP *********************************************************************
2018-11-28T13:21:49.702 INFO:teuthology.orchestra.run.argo016.stdout:argo016.ceph.redhat.com    : ok=99   changed=16   unreachable=0    failed=0
2018-11-28T13:21:49.702 INFO:teuthology.orchestra.run.argo016.stdout:argo019.ceph.redhat.com    : ok=66   changed=7    unreachable=0    failed=1
2018-11-28T13:21:49.702 INFO:teuthology.orchestra.run.argo016.stdout:argo021.ceph.redhat.com    : ok=63   changed=7    unreachable=0    failed=1
2018-11-28T13:21:49.703 INFO:teuthology.orchestra.run.argo016.stdout:argo027.ceph.redhat.com    : ok=89   changed=14   unreachable=0    failed=0
2018-11-28T13:21:49.703 INFO:teuthology.orchestra.run.argo016.stdout:argo028.ceph.redhat.com    : ok=141  changed=24   unreachable=0    failed=0
2018-11-28T13:21:49.703 INFO:teuthology.orchestra.run.argo016.stdout:argo031.ceph.redhat.com    : ok=63   changed=7    unreachable=0    failed=1
2018-11-28T13:21:49.703 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.704 INFO:teuthology.orchestra.run.argo016.stdout:
2018-11-28T13:21:49.704 INFO:teuthology.orchestra.run.argo016.stdout:INSTALLER STATUS ***************************************************************

Comment 8 errata-xmlrpc 2019-01-03 19:02:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.