Bug 1654445 - role & addons should not affect entitlement compliance status
Summary: role & addons should not affect entitlement compliance status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.5
Assignee: Nikos Moumoulidis
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1652737
Blocks: 1652738
TreeView+ depends on / blocked
 
Reported: 2018-11-28 20:05 UTC by Nikos Moumoulidis
Modified: 2018-11-30 14:45 UTC (History)
3 users (show)

Fixed In Version: candlepin-2.5.8-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1652737
Environment:
Last Closed: 2018-11-30 14:45:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin candlepin pull 2166 None None None 2018-11-28 21:39:36 UTC

Description Nikos Moumoulidis 2018-11-28 20:05:37 UTC
+++ This bug was initially created as a clone of Bug #1652737 +++

Description of problem:
When syspurpose role or addon(s) are specified on the client, and the system is attached to a subscription that happens to have mismatched roles/addons with those of the consumer, the Entitlement Compliance status is wrongly reported as invalid or insufficient. role/addon attributes should only have an effect on the Syspurpose Compliance status, and not on the Entitlement Compliance status.

Version-Release number of selected component (if applicable):
candlepin 2.3, 2.5 and master

How reproducible:
100%

Steps to Reproduce:
1. Set your system syspurpose role to 'my_role'.
2. Have an installed product called 'product1'.
3. Attach the system to a subscription that provides product1, but the only role it has is 'provided_role'.
4. Run 'subscription-manager status' to see the Overall Status

Actual results:
The Overall Status is either 'invalid' or 'partial'.

Expected results:
The Overall Status should be 'valid', because product1 is covered, and roles/addons should have no effect on it.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.