Bug 1654479 - Productid is temporarily not available during a CV publish
Summary: Productid is temporarily not available during a CV publish
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.4
Hardware: aarch64
OS: Linux
low
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Kersom
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-11-28 21:16 UTC by Mihir Lele
Modified: 2019-08-08 02:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 17:38:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mihir Lele 2018-11-28 21:16:52 UTC
Description of problem:

Yum throws "404 resource not found" erors on the hosts for some seconds during the time when CV publish task is running and when host is trying to pull metadata/packages.

Version-Release number of selected component (if applicable): 6.4


How reproducible: ??

Steps to Reproduce:
1. Initiate a CV publish task on the Satellite
2. Run "yum update" on the hosts in a frequent loop so that the host connects to the Satellite


Actual results:

Yum throws "404 resource not found" erors on the hosts

Expected results:

Yum should be able to access the productid files from the Satellite

Additional info:

Errors:

  Installing : pulp-rpm-admin-extensions-2.16.4.1-5.el7sat.noarch                                                            6/6
Uploading Package Profile
https://satellite.example.com/pulp/repos/acmeinc/Hostgroup/hostgroup2_sat-6_4-ci/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/productid: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

https://satellite.example.com/pulp/repos/acmeinc/Hostgroup/hostgroup2_sat-6_4-ci/content/dist/rhel/server/7/7Server/x86_64/satellite/6.4/os/repodata/productid: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
https://satellite.example.com/pulp/repos/acmeinc/Hostgroup/hostgroup2_sat-6_4-ci/content/dist/rhel/server/7/7Server/x86_64/sat-capsule/6.4/os/repodata/productid: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.


This issue lasts for only few seconds and get automatically resolved.

Comment 3 Peter Vreman 2019-04-30 07:03:33 UTC
So far i have not been able to reproduce it, it might be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1659549

Comment 4 Brad Buckingham 2019-06-10 11:44:00 UTC
Hello Peter,

I am unable to reproduce this one as well.  It is quite possible that the bugzilla referenced resolved the behavior; however, I am not able to say with absolute certainty.  That said, there were several fixes in this release cycle.

Would you like to keep this one open to continue to monitor?

Comment 5 Peter Vreman 2019-06-11 10:40:00 UTC
Brad,

I did not see any 404 or ERROR reported for pulp_streamer like it was in the past when i opened the Case / BZ.

Lets close this BZ as fixed in current release.

Peter


Note You need to log in before you can comment on or make changes to this bug.