Bug 165448 - large non-editable combo boxes fill entire screen with bluecurve theme
large non-editable combo boxes fill entire screen with bluecurve theme
Status: CLOSED DUPLICATE of bug 157809
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 10:48 EDT by Craig Ringer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 11:35:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case for bug (784 bytes, text/plain)
2005-08-09 10:50 EDT, Craig Ringer
no flags Details

  None (edit)
Description Craig Ringer 2005-08-09 10:48:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Large combo boxes that are not user ediable (ie QComboBox::setEditable(false)) fill the whole screen when the user is using the bluecurve theme. Such long combo boxes are probably a UI issue with the app using them, but nonetheless there's a bug here.

In addition to filling the screen it appears impossible to scroll them or type-ahead-find in them.

Version-Release number of selected component (if applicable):
qt-3.3.4-15.1

How reproducible:
Always

Steps to Reproduce:
1. Run `qtconfig' and ensure the style is set to `bluecurve' (Style=Bluecurve in ~/.qt/qtrc)
2. Run the test program.
3. Click the combo box - do not hold down the mouse button (so you can observe the keyboard issues; the other behaviours are present whether or not you click-and-hold).

Actual Results:  As described above - combo box listing fills screen, is not scrollable, and ignores keyboard input.

Expected Results:  Sane combo box behaviour - type ahead find works, combo box listing doesn't take up whole display, is scrollable.

Additional info:
Comment 1 Craig Ringer 2005-08-09 10:50:50 EDT
Created attachment 117574 [details]
Test case for bug

See the comments at the top of the file for build instructions.
Comment 2 Craig Ringer 2005-08-09 10:52:32 EDT
The bug is not x86_64 specific, and affects my i686 system too, so switched arch.
Comment 3 Ngo Than 2005-08-09 11:35:59 EDT

*** This bug has been marked as a duplicate of 157809 ***
Comment 4 Craig Ringer 2005-08-09 11:43:43 EDT
Odd ... didn't find that when searching bugzilla. I must be blind. Sorry for the
wasted time.

Note You need to log in before you can comment on or make changes to this bug.