Bug 1654482 - [Tech Preview] Print warning that Cluster-aware MD RAID1 is Tech Preview [NEEDINFO]
Summary: [Tech Preview] Print warning that Cluster-aware MD RAID1 is Tech Preview
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: mdadm
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Nigel Croxon
QA Contact: ChanghuiZhong
Apurva Bhide
URL:
Whiteboard:
Depends On:
Blocks: 1643541
TreeView+ depends on / blocked
 
Reported: 2018-11-28 21:27 UTC by Jonathan Earl Brassow
Modified: 2019-07-23 18:15 UTC (History)
13 users (show)

Fixed In Version: mdadm-4.1-2.el8
Doc Type: Enhancement
Doc Text:
.The cluster-aware MD RAID1 is now fully supported The cluster-aware MD RAID1, previously available as a Technology Preview, is now fully supported. RAID1 cluster is not enabled by default in the kernel space. If you want to have a try with RAID1 cluster, you need to build the kernel with RAID1 cluster as a module first, use the following steps: . Enter the `make menuconfig` command. . Enter the `make && make modules && make modules_install && make install` command. . Enter the `reboot` command.
Clone Of:
Environment:
Last Closed: 2019-06-14 01:43:36 UTC
Type: Bug
abhide: needinfo? (ncroxon)
abhide: needinfo? (ncroxon)


Attachments (Terms of Use)

Description Jonathan Earl Brassow 2018-11-28 21:27:03 UTC
Ensure that users of cluster-aware active/active MD RAID1 are adequately warned that the feature is Tech Preview.

Marian Csontos <mcsontos@redhat.com> has put these warnings in place before for LVM features.  Consult him if you have questions.

Considering the fact that this feature is already in RHEL8, I consider the lack of the warning to be a bug, not a feature.  (We will also need relevant documentation.)

Comment 1 Nigel Croxon 2018-11-28 21:55:13 UTC
From 8625714f216e4f868ca1acbac7c55820d441b5e2 Mon Sep 17 00:00:00 2001
From: Nigel Croxon <ncroxon@redhat.com>
Date: Wed, 28 Nov 2018 16:39:43 -0500
Subject: [PATCH] add tech preview msg to bitmap=clustered

RHEL-ONLY
Since we do not fully support --bitmap=clustered for RAID1/10.
We are adding a message, telling the user that this feature
is in Tech Preview.

Signed-off-by: Nigel Croxon <ncroxon@redhat.com>
---
 mdadm-4.1_rc1/mdadm.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/mdadm-4.1_rc1/mdadm.c b/mdadm-4.1_rc1/mdadm.c
index 5afe415..a9bbe38 100644
--- a/mdadm-4.1_rc1/mdadm.c
+++ b/mdadm-4.1_rc1/mdadm.c
@@ -1553,6 +1553,8 @@ int main(int argc, char *argv[])
 			c.delay = DEFAULT_BITMAP_DELAY;
 
 		if (c.nodes) {
+			pr_err("The bitmap=clustered is a Red Hat Technology Preview Feature.\n");
+
 			if (!s.bitmap_file ||
 			    strcmp(s.bitmap_file, "clustered") != 0) {
 				pr_err("--nodes argument only compatible with --bitmap=clustered\n");
-- 
1.8.3.1

Comment 3 Nigel Croxon 2018-12-05 20:21:27 UTC
From 2adaad72947bf3114de05ef327b3ceb31bb3f9dc Mon Sep 17 00:00:00 2001
From: Nigel Croxon <ncroxon@redhat.com>
Date: Wed, 5 Dec 2018 11:27:40 -0500
Subject: [PATCH] add tech preview msg to bitmap=clustered

bugzilla: 1654482
https://bugzilla.redhat.com/show_bug.cgi?id=1654482

RHEL-ONLY
Since we do not fully support --bitmap=clustered for RAID1/10.
We are adding a message, telling the user that this feature
is in Tech Preview.

Signed-off-by: Nigel Croxon <ncroxon@redhat.com>
---
 mdadm-4.1_rc1/mdadm.c | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/mdadm-4.1_rc1/mdadm.c b/mdadm-4.1_rc1/mdadm.c
index 5afe415..c094126 100644
--- a/mdadm-4.1_rc1/mdadm.c
+++ b/mdadm-4.1_rc1/mdadm.c
@@ -1553,6 +1553,10 @@ int main(int argc, char *argv[])
 			c.delay = DEFAULT_BITMAP_DELAY;
 
 		if (c.nodes) {
+			pr_err("WARNING: bitmap=clustered is Technology Preview.\n");
+			pr_err("For more information on Technology Preview features, visit:\n");
+			pr_err("https://access.redhat.com/support/offerings/techpreview/ \n");
+
 			if (!s.bitmap_file ||
 			    strcmp(s.bitmap_file, "clustered") != 0) {
 				pr_err("--nodes argument only compatible with --bitmap=clustered\n");
-- 
1.8.3.1

Comment 6 ChanghuiZhong 2018-12-13 03:36:43 UTC
Hi,XiaoNi

Can you provide a more detailed about environment setup, for my part, I can't successfully reproduce your operation:

[root@storageqe-09 ~]# mdadm --create md0 --level=mirror --bitmap=clustered --raid-devices=2 --assume-clean /dev/sdb1 /dev/sdc1
Mdadm: The md can't get cluster name
[root@storageqe-09 ~]#

There is a reminder message about "please update the tmpfiles.d" when installing the RPM package for mdadm-4.1-2.el8:

[root@storageqe-09 ~]# rpm -ivh mdadm-4.1-2.el8.x86_64.rpm
Verifying... ####################################### [100%]
Preparing... ####################################### [100%]
Updating / installing...
   1:mdadm-4.1-2.el8 ########################################[100%]
[/usr/lib/tmpfiles.d/mdadm.conf:1] Line references path below legacy directory /var/run/, updating /var/run/mdadm → /run/mdadm; please update the tmpfiles.d/ drop- In file accordingly.
[/usr/lib/tmpfiles.d/pesign.conf:1] Line references path below legacy directory /var/run/, updating /var/run/pesign → /run/pesign; please update the tmpfiles.d/ drop- In file accordingly.
[/usr/lib/tmpfiles.d/subscription-manager.conf:1] Line references path below legacy directory /var/run/, updating /var/run/rhsm → /run/rhsm; please update the tmpfiles.d/ Drop-in file accordingly.
[root@storageqe-09 ~]#

thanks,
czhong

Comment 8 Corey Marthaler 2019-01-11 17:04:43 UTC
I can verify the proper "Technology Preview" message is printed. That said this functionality still *doesn't* work. I'll add that info to the other BZ (1650338).

[root@hayes-03 ~]# pcs status
Cluster name: HAYES
Stack: corosync
Current DC: hayes-03 (version 2.0.1-2.el8-0eb7991564) - partition with quorum
Last updated: Fri Jan 11 11:02:32 2019
Last change: Fri Jan 11 10:54:29 2019 by root via cibadmin on hayes-03

1 node configured
2 resources configured

Online: [ hayes-03 ]

Full list of resources:

 smoke-apc      (stonith:fence_apc):    Started hayes-03
 Clone Set: dlm-clone [dlm]
     Started: [ hayes-03 ]


[root@hayes-03 ~]# mdadm --create md0 --bitmap=clustered --raid-devices=2 --level=mirror --assume-clean /dev/sdc1 /dev/sdd1
mdadm: WARNING: bitmap=clustered is Technology Preview.
mdadm: For more information on Technology Preview features, visit:
mdadm: https://access.redhat.com/support/offerings/techpreview/ 
mdadm: Note: this array has metadata at the start and
    may not be suitable as a boot device.  If you plan to
    store '/boot' on this device please ensure that
    your boot-loader understands md/v1.x metadata, or use
    --metadata=0.90
Continue creating array? (y/n) y
mdadm: Defaulting to version 1.2 metadata
mdadm: RUN_ARRAY failed: No such file or directory

[root@hayes-03 ~]# echo $?
1

Comment 9 ChanghuiZhong 2019-01-21 09:38:00 UTC
I also encountered the same problem, "Technology Preview" message is printed, but failed to create md with cluster

[root@intel-mahobay-01 ~]# uname -r
4.18.0-56.el8.x86_64
[root@intel-mahobay-01 ~]#
[root@intel-mahobay-01 ~]#
[root@intel-mahobay-01 ~]# rpm -q mdadm
mdadm-4.1-2.el8.x86_64
[root@intel-mahobay-01 ~]#
[root@intel-mahobay-01 ~]# pcs status
Cluster name: my_cluster
Stack: corosync
Current DC: intel-mahobay-02.lab.eng.rdu.redhat.com (version 2.0.1-3.el8-0eb7991564) - partition with quorum
Last updated: Mon Jan 21 02:42:49 2019
Last change: Mon Jan 21 02:34:42 2019 by root via cibadmin on intel-mahobay-01.lab.eng.rdu.redhat.com

2 nodes configured
3 resources configured

Online: [ intel-mahobay-01.lab.eng.rdu.redhat.com intel-mahobay-02.lab.eng.rdu.redhat.com ]

Full list of resources:

 scsi_fecing_device    (stonith:fence_scsi):    Started intel-mahobay-01.lab.eng.rdu.redhat.com
 Clone Set: dlm-clone [dlm]
     Started: [ intel-mahobay-01.lab.eng.rdu.redhat.com intel-mahobay-02.lab.eng.rdu.redhat.com ]

Failed Fencing Actions:
* unfencing of intel-mahobay-02.lab.eng.rdu.redhat.com failed: delegate=, client=pacemaker-controld.5777, origin=intel-mahobay-02.lab.eng.rdu.redhat.com,
    last-failed='Mon Jan 21 02:08:11 2019'
* unfencing of intel-mahobay-01.lab.eng.rdu.redhat.com failed: delegate=, client=pacemaker-controld.5777, origin=intel-mahobay-02.lab.eng.rdu.redhat.com,
    last-failed='Mon Jan 21 02:08:10 2019'

Daemon Status:
  corosync: active/enabled
  pacemaker: active/enabled
  pcsd: active/enabled
[root@intel-mahobay-01 ~]#
[root@intel-mahobay-01 ~]#
[root@intel-mahobay-01 ~]# mdadm --create md0 --bitmap=clustered --raid-devices=2 --level=mirror --assume-clean /dev/mapper/mpatha1 /dev/mapper/mpathb1
mdadm: WARNING: bitmap=clustered is Technology Preview.
mdadm: For more information on Technology Preview features, visit:
mdadm: https://access.redhat.com/support/offerings/techpreview/
mdadm: Note: this array has metadata at the start and
    may not be suitable as a boot device.  If you plan to
    store '/boot' on this device please ensure that
    your boot-loader understands md/v1.x metadata, or use
    --metadata=0.90
mdadm: largest drive (/dev/mapper/mpatha1) exceeds size (4189440K) by more than 1%
Continue creating array? y
mdadm: Defaulting to version 1.2 metadata
mdadm: RUN_ARRAY failed: No such file or directory
[root@intel-mahobay-01 ~]# echo $?
1
[root@intel-mahobay-01 ~]#

Comment 10 David Teigland 2019-03-13 17:26:56 UTC
> mdadm: RUN_ARRAY failed: No such file or directory

It looks like the md_cluster module is not enabled in RHEL8 kernels.  On an upstream kernel I got this error before loading the module.

Comment 11 XiaoNi 2019-03-20 15:48:41 UTC
(In reply to David Teigland from comment #10)
> > mdadm: RUN_ARRAY failed: No such file or directory
> 
> It looks like the md_cluster module is not enabled in RHEL8 kernels.  On an
> upstream kernel I got this error before loading the module.

Hi David

Thanks for this information. It should be built as module and there is a bug
to enable it https://bugzilla.redhat.com/show_bug.cgi?id=1650338

Thanks
Xiao

Comment 23 Nigel Croxon 2019-07-11 17:57:42 UTC
Remove the Tech Preview for RAID1 Clustering in the Release Notes for 8.1
-Nigel


Note You need to log in before you can comment on or make changes to this bug.