Bug 1654525 - heat_tempest_plugin.tests.scenario.test_volumes.VolumeBackupRestoreIntegrationTest.test_cinder_volume_create_backup_restore was run even if cinder-backup is not configured.
Summary: heat_tempest_plugin.tests.scenario.test_volumes.VolumeBackupRestoreIntegratio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-heat-tests-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z6
: 13.0 (Queens)
Assignee: Rabi Mishra
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks: 1688076
TreeView+ depends on / blocked
 
Reported: 2018-11-29 01:35 UTC by Keigo Noha
Modified: 2019-04-30 17:23 UTC (History)
3 users (show)

Fixed In Version: python-heat-tests-tempest-0.3.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1688076 (view as bug list)
Environment:
Last Closed: 2019-04-30 17:23:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 632989 None master: MERGED heat-tempest-plugin: Skip tests based on service features disabled in tempest (I7a2495182791595c87f8245ff5e13dfd841b013f... 2019-04-08 15:46:12 UTC
Red Hat Product Errata RHBA-2019:0926 None None None 2019-04-30 17:23:53 UTC

Description Keigo Noha 2018-11-29 01:35:54 UTC
Description of problem:
heat_tempest_plugin.tests.scenario.test_volumes.VolumeBackupRestoreIntegrationTest.test_cinder_volume_create_backup_restore was run even if cinder-backup is not configured.
Running this test case without cinder-backup causes:
1. A stack with DELETE_FAILED status.
2. User can not delete the case until the user changes the status of volume resource created
in mariadb database directly. 


Version-Release number of selected component (if applicable):
Current heat_tests_tempest

How reproducible:
Everytime when user runs the tests.

Steps to Reproduce:
1. Deploy undercloud and overcloud without cinder-backup
2. Configure tempest with heat_plugins section.
3. Run tempest.

Actual results:
The test scenario was run and causes stack cannot be deleted.

Expected results:
The test scenario should not be run if cinder-backup is not configured.

Additional info:

Comment 9 errata-xmlrpc 2019-04-30 17:23:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0926


Note You need to log in before you can comment on or make changes to this bug.