Bug 1654588 - [rfe]: rgw: does not support lifecycle rules whose filters a) lack PREFIX b) contain TAG c) use AND/conjunction [NEEDINFO]
Summary: [rfe]: rgw: does not support lifecycle rules whose filters a) lack PREFIX b) ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 3.2
Assignee: Matt Benjamin (redhat)
QA Contact: vidushi
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-11-29 07:44 UTC by Karun Josy
Modified: 2019-03-07 15:51 UTC (History)
15 users (show)

Fixed In Version: RHEL: ceph-12.2.8-89.el7cp Ubuntu: ceph_12.2.8-75redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Lifecycle rules with multiple tag filters are no longer rejected Due to a bug in lifecycle rule processing, an attempt to install the lifecycle rules with multiple tag filters was rejected and the `InvalidRequest` error message was returned. With this update, other rule forms are used, and lifecycle rules with multiple tag filters are no longer rejected.
Clone Of:
Environment:
Last Closed: 2019-03-07 15:51:12 UTC
igreen: needinfo? (mbenjamin)


Attachments (Terms of Use)
test_lc_xml_doesnt_work (992 bytes, text/plain)
2018-11-29 07:44 UTC, Karun Josy
no flags Details
rgw-debug-log (55.95 KB, text/plain)
2018-11-29 07:48 UTC, Karun Josy
no flags Details
test with hotfix (4.20 KB, text/plain)
2019-02-13 17:29 UTC, Ilan Green
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0475 None None None 2019-03-07 15:51:24 UTC
Ceph Project Bug Tracker 37879 None None None 2019-01-11 21:17:36 UTC

Description Karun Josy 2018-11-29 07:44:04 UTC
Created attachment 1509748 [details]
test_lc_xml_doesnt_work

* Description of problem:

When creating and uploading a lifecycle configuration which has 2 rules with tags for objects and using "Filter" option;  it doesn't work. 
In such cases when using setlifecycle command, it gives "S3 error: 400 (InvalidRequest)".

* Version-Release number of selected component (if applicable):
3.1

* How reproducible:
Always

* Steps to Reproduce:

- Download the script attached "test_lc_xml_doesnt_work"
- Create a bucket
- Use s3cmd to set the lc policy
   # s3cmd setlifecycle test_lc_xml_doesnt_work s3://bucket-name


Actual results:
   # s3cmd setlifecycle test_lc_xml_doesnt_work s3://lctest
   ERROR: S3 error: 400 (InvalidRequest)

Expected results:
 # s3cmd setlifecycle test_lc_xml_doesnt_work s3://lctest
 s3://lctest/:   Policy updated.

Additional info:
For the same configuration, if we use "Prefix" option instead of "Filter"  it works.

Comment 3 Karun Josy 2018-11-29 07:46:50 UTC
I have also attached the rgw  log with debug level 20.
----
# date
Thu Nov 29 13:10:59 IST 2018
# s3cmd setlifecycle test_lc_xml_doesnt_work s3://lctest
ERROR: S3 error: 400 (InvalidRequest)
------

Comment 4 Karun Josy 2018-11-29 07:48:19 UTC
Created attachment 1509749 [details]
rgw-debug-log

Comment 44 Ilan Green 2019-02-13 17:29:29 UTC
Created attachment 1534473 [details]
test with hotfix

Comment 68 errata-xmlrpc 2019-03-07 15:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475


Note You need to log in before you can comment on or make changes to this bug.