Bug 1654593 - ../../gdb/dwarf2read.c:9818: internal-error
Summary: ../../gdb/dwarf2read.c:9818: internal-error
Keywords:
Status: CLOSED DUPLICATE of bug 1560010
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Durigan Junior
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 07:58 UTC by Tomasz Kłoczko
Modified: 2018-11-29 17:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-29 17:47:09 UTC


Attachments (Terms of Use)

Description Tomasz Kłoczko 2018-11-29 07:58:07 UTC
Recently I found lftp crashing in binary build by me so I've been trying to check generated core file:

[root@domek coredump]# gdb -c core.lftp.1000.a541c9601bb747ea906170a1934b8dde.10037.1543472771000000 
GNU gdb (GDB) Fedora 8.2.50.20181114-9.fc30
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word".
[New LWP 10037]
Reading symbols from /usr/bin/lftp...
Reading symbols from /usr/lib/debug/usr/bin/lftp-4.8.4-2.fc30.x86_64.debug...
../../gdb/dwarf2read.c:9818: internal-error: void dw2_add_symbol_to_list(symbol*, pending**): Assertion `(*listhead) == NULL || (SYMBOL_LANGUAGE ((*listhead)->symbol[0]) == SYMBOL_LANGUAGE (symbol))' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) n

This is a bug, please report it.  For instructions, see:
<http://www.gnu.org/software/gdb/bugs/>.

../../gdb/dwarf2read.c:9818: internal-error: void dw2_add_symbol_to_list(symbol*, pending**): Assertion `(*listhead) == NULL || (SYMBOL_LANGUAGE ((*listhead)->symbol[0]) == SYMBOL_LANGUAGE (symbol))' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Create a core file of GDB? (y or n) n
Command aborted.
warning: Unexpected size of section `.reg-xstate/10037' in core file.
(gdb) bt
#0  0x00007efe5b82653f in ?? ()
#1  0x0000000000010000 in ?? ()
#2  0x00005643e6295ac0 in ?? ()
#3  0x00007efe5b9afd80 in ?? ()
#4  0x00007efe5b868927 in ?? ()
#5  0x00007ffcfbad8000 in ?? ()
#6  0x00005643e6295ac0 in ?? ()
#7  0x00005643e6295b25 in ?? ()
#8  0x00005643e6295ac0 in ?? ()
#9  0x00005643e6295ac0 in ?? ()
#10 0x00005643e6295b36 in ?? ()
#11 0x00005643e6295bec in ?? ()
#12 0x00005643e6295ac0 in ?? ()
#13 0x00005643e6295bec in ?? ()
#14 0x0000000000000000 in ?? ()
(gdb)

Comment 1 Sergio Durigan Junior 2018-11-29 17:47:09 UTC
Thanks for the report.  We're aware of this bug and tracking its progress on Bug 1560010, therefore I'm closing this one as a duplicate.  Feel free to subscribe to the other bug if you want to follow its progress.

*** This bug has been marked as a duplicate of bug 1560010 ***


Note You need to log in before you can comment on or make changes to this bug.