Bug 1654644 - ProxyFactory.getResource for StorageService fails with Could not create custom interface
Summary: ProxyFactory.getResource for StorageService fails with Could not create custo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: CLI
Version: JON 3.3.11
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ER01
: JON 3.3.12
Assignee: Josejulio Martínez
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 10:28 UTC by Filip Brychta
Modified: 2019-06-27 15:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-27 15:58:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4246741 Troubleshoot None JBoss ON CLI method ProxyFactory.getResource fails for StorageService: Could not create custom interface 2019-06-25 20:26:17 UTC
Red Hat Product Errata RHBA-2019:1631 None None None 2019-06-27 15:58:49 UTC

Description Filip Brychta 2018-11-29 10:28:00 UTC
Description of problem:
ProxyFactory.getResource(10028) where 10028 is id of Storage Service StorageService fails with java.lang.IllegalStateException: Could not create custom interface for resource with id 10028

Version-Release number of selected component (if applicable):
JON 3.3.11

How reproducible:
Always

Steps to Reproduce:
1. start JON 3.3.11
2. download command line client (e.g. wget http://<yourServer>:7080/client/download)
3. unzip and login to the JON server:  e.g. ./rhq-cli.sh -s jon3x-server.bc.jonqe.lab.eng.bos.redhat.com -u user -p passw
4. in JON UI find id of Storage Service resource (RHQ Storage Node->Database Management Services->Storage Service) 

Actual results:
StorageService fails with java.lang.IllegalStateException: Could not create custom interface for resource with id 10028

Expected results:
No failures

Additional info:
Not a regression, visible in JON 3.3.10 too

Comment 1 Filip Brychta 2018-11-29 16:08:03 UTC
Adding missing step: 5. run ProxyFactory.getResource(10028) where 10028 is id from step 4

Comment 2 Josejulio Martínez 2019-03-07 16:26:31 UTC
commit bbb17bc45c1efd85a730c2c182f5d4c38ac943a4 (HEAD -> master)
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Wed Mar 6 11:01:07 2019 -0600

    Bug 1654644 - Check instance type before casting to PropertyDefinitionSimple

Comment 7 errata-xmlrpc 2019-06-27 15:58:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1631


Note You need to log in before you can comment on or make changes to this bug.