Bug 1654672 - Optimize puppet RPM spec for systemd requirements when installing it in containers
Summary: Optimize puppet RPM spec for systemd requirements when installing it in conta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: puppet
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 11:44 UTC by Bogdan Dobrelya
Modified: 2019-03-29 19:17 UTC (History)
10 users (show)

Fixed In Version: puppet-5.5.10-4.fc29 puppet-5.5.10-4.fc28 puppet-5.5.10-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1654659
: 1668678 (view as bug list)
Environment:
Last Closed: 2019-03-27 03:27:17 UTC


Attachments (Terms of Use)
patch (1.65 KB, patch)
2018-11-29 11:44 UTC, Bogdan Dobrelya
no flags Details | Diff
final patch (1.67 KB, patch)
2018-11-30 10:23 UTC, Bogdan Dobrelya
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Launchpad 1804822 None None None 2018-11-29 11:44:20 UTC

Description Bogdan Dobrelya 2018-11-29 11:44:21 UTC
Created attachment 1509791 [details]
patch

+++ This bug was initially created as a clone of Bug #1654659 +++

Description of problem:

When installing puppet into a container image, it is preferable to use the systemd_ordering macro.

According to https://fedoraproject.org/wiki/Packaging:Scriptlets:
If a package is suitable for installation without systemd (in a
container image, for example) and does not require any of the
systemd mechanisms such as tmpfiles.d, then the systemd_ordering macro
MAY be used instead of the systemd_requires macro. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Bogdan Dobrelya on 2018-11-29 06:20:58 EST ---

It would be also very nice to have this for Fedora28. Please let me know if I have to clone this bug for that release? (Not sure what to do to the patch then, I submitted it against master of https://src.fedoraproject.org/rpms/puppet repo, and I can see no stable branches there)

Comment 1 Terje Røsten 2018-11-29 18:02:27 UTC
Drop support for Fedora 27 and older, its obsolete any way.
Please create PR in pagure.

Thanks!

Comment 2 Bogdan Dobrelya 2018-11-30 10:13:03 UTC
@Terje, thanks! I'll start wrapping my head around that pague and learning the contributing workflow now! :)

Just to clarify the case for puppet w/o systemd, in TripleO (OpenStack installer) we have config-containers that run only a limited tags off puppet manifests. Like we only tell it to configure files and shoot execs, but not touch services (systemd) and packaging configuration aspects.

Comment 4 Bogdan Dobrelya 2018-11-30 10:23:24 UTC
Created attachment 1510100 [details]
final patch

Comment 5 Bogdan Dobrelya 2019-01-04 11:56:29 UTC
Hey folks.
Happy New Year!

Any updates on that, is the proposed patch alright?

Comment 6 Bogdan Dobrelya 2019-01-21 13:43:09 UTC
Hello.
I'd love to receive some guidance for the next steps required for getting the patch merged. Thanks!

Comment 7 Bogdan Dobrelya 2019-01-21 13:49:57 UTC
Note, there is no puppet can be found in https://pagure.io/browse/projects/
Is that me doing it wrong? :)

Comment 8 Terje Røsten 2019-01-21 20:32:07 UTC
https://src.fedoraproject.org/rpms/puppet ?

Comment 9 Terje Røsten 2019-01-21 20:37:39 UTC
Sorry, I confused you with my pagure comment, Fedora is running an pagure *instance*, its hosted as 
https://src.fedoraproject.org/ I don't mean the pagure project itself.

Each package in Fedora is a submodule in the pagure instance, the puppet package is hosted here:
 https://src.fedoraproject.org/rpms/puppet

You can create a pull request in this system.

Comment 10 Bogdan Dobrelya 2019-01-22 15:21:11 UTC
Here is a PR against the master https://src.fedoraproject.org/rpms/puppet/pull-request/1

Comment 11 Bogdan Dobrelya 2019-01-22 15:24:41 UTC
And a backport of it for the f29 branch https://src.fedoraproject.org/rpms/puppet/pull-request/2

I hope that works.
Thank you for explaining the pagure magic, Terje ;)

Comment 12 Terje Røsten 2019-01-22 20:16:55 UTC
Pushed. Thanks for patch!

I added a changelog, please do that in future PRs, also remember to bump release.

Comment 13 Fedora Update System 2019-01-22 20:18:43 UTC
puppet-5.5.6-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-035aaa739d

Comment 14 Fedora Update System 2019-01-23 02:25:01 UTC
puppet-5.5.6-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-035aaa739d

Comment 15 Bogdan Dobrelya 2019-01-25 15:23:18 UTC
So I checked out the package, and I can still see systemd in requirements

# repoquery --requires --resolve puppet | grep systemd
systemd-0:240-6.gitf02b547.fc30.i686
systemd-0:240-6.gitf02b547.fc30.x86_64
# dnf list puppet
Installed Packages
puppet.noarch                                      5.5.6-3.fc29                                       @ftp.icm.edu.pl_pub_Linux_fedora_linux_updates_testing_29_Everything_x86_64_

not good :(

Comment 16 Terje Røsten 2019-01-28 18:37:40 UTC
I get different results:


$ dnf repoquery --enablerepo=updates-testing --requires --resolve puppet-0:5.5.6-3.fc29.noarch

bash-0:4.4.23-6.fc29.x86_64
hiera-0:3.3.1-4.fc29.noarch
jruby-0:1.7.22-7.fc29.noarch
libselinux-ruby-0:2.8-6.fc29.x86_64
libselinux-utils-0:2.8-6.fc29.x86_64
ruby-0:2.5.3-100.fc29.i686
ruby-0:2.5.3-100.fc29.x86_64
ruby-augeas-0:0.5.0-18.fc29.x86_64
ruby-facter-0:3.9.3-5.fc29.x86_64
ruby-libs-0:2.5.3-100.fc29.i686
ruby-libs-0:2.5.3-100.fc29.x86_64
rubygem-json-0:2.1.0-106.fc29.x86_64
rubygem-pathspec-0:0.2.1-3.fc29.noarch
rubygem-rgen-0:0.7.0-7.fc29.noarch
rubygem-ruby-shadow-0:2.5.0-7.fc29.x86_64
rubypick-0:1.1.1-9.fc29.noarch
shadow-utils-2:4.6-4.fc29.x86_64
tar-2:1.30-6.fc29.x86_64


$ dnf repoquery --enablerepo=updates-testing --requires  --resolve puppet-0:5.5.1-2.fc29       

bash-0:4.4.23-6.fc29.x86_64
hiera-0:3.3.1-4.fc29.noarch
jruby-0:1.7.22-7.fc29.noarch
libselinux-ruby-0:2.8-6.fc29.x86_64
libselinux-utils-0:2.8-6.fc29.x86_64
ruby-0:2.5.3-100.fc29.i686
ruby-0:2.5.3-100.fc29.x86_64
ruby-augeas-0:0.5.0-18.fc29.x86_64
ruby-facter-0:3.9.3-5.fc29.x86_64
ruby-libs-0:2.5.3-100.fc29.i686
ruby-libs-0:2.5.3-100.fc29.x86_64
rubygem-json-0:2.1.0-106.fc29.x86_64
rubygem-pathspec-0:0.2.1-3.fc29.noarch
rubygem-rgen-0:0.7.0-7.fc29.noarch
rubygem-ruby-shadow-0:2.5.0-7.fc29.x86_64
rubypick-0:1.1.1-9.fc29.noarch
shadow-utils-2:4.6-4.fc29.x86_64
systemd-0:239-9.gite339eae.fc29.i686
systemd-0:239-9.gite339eae.fc29.x86_64
tar-2:1.30-6.fc29.x86_64

Seems fixed to me.

Comment 17 Bogdan Dobrelya 2019-01-29 12:57:28 UTC
Thank you for testing this Terje!
That's something wrong on my side then it seems :)

Comment 18 Bogdan Dobrelya 2019-02-11 13:32:14 UTC
Unfortunately, we have to revert because of https://github.com/rpm-software-management/dnf/pull/1315#issuecomment-462321911

Comment 19 Bogdan Dobrelya 2019-02-11 13:39:16 UTC
Reverts proposed for puppet master https://src.fedoraproject.org/rpms/puppet/pull-request/3, f29 https://src.fedoraproject.org/rpms/puppet/pull-request/4

Comment 20 Fedora Update System 2019-02-17 21:28:28 UTC
puppet-5.5.6-5.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-066a6723b5

Comment 21 Fedora Update System 2019-02-18 03:05:55 UTC
puppet-5.5.6-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-066a6723b5

Comment 22 Fedora Update System 2019-02-26 03:05:29 UTC
puppet-5.5.6-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Bogdan Dobrelya 2019-03-05 17:06:22 UTC
Reworked for master https://src.fedoraproject.org/rpms/puppet/pull-request/5

Comment 24 Bogdan Dobrelya 2019-03-05 17:09:33 UTC
Note, for downstream-only, it has been accidently fixed already, see https://brewweb.engineering.redhat.com/brew/rpminfo?rpmID=6775664 :)

Comment 25 Terje Røsten 2019-03-07 19:08:57 UTC
I did a modified version:

 https://src.fedoraproject.org/cgit/rpms/puppet.git/commit/?id=f04e1ae2d44629a2d89df0ee1a1da0d53f3550d7

 https://koji.fedoraproject.org/koji/buildinfo?buildID=1226327

it avoids adding two new packages (one new package is enough) and sets conflicts to get upgrades correct.

Seems like URL above is not reachable?

Comment 26 Bogdan Dobrelya 2019-03-11 09:40:36 UTC
@Terje, the links above loog good. 
Thank you for the solution, it works perfectly fine!

Mind updating the bug status please, like posting a link to the patch or set it to POST, if merged?

Comment 27 Fedora Update System 2019-03-17 10:42:10 UTC
puppet-5.5.10-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-809349a09a

Comment 28 Fedora Update System 2019-03-17 10:42:20 UTC
puppet-5.5.10-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-12399acdc5

Comment 29 Fedora Update System 2019-03-17 10:42:29 UTC
puppet-5.5.10-4.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1fa9b7403

Comment 30 Fedora Update System 2019-03-17 20:59:22 UTC
puppet-5.5.10-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1fa9b7403

Comment 31 Fedora Update System 2019-03-18 03:12:41 UTC
puppet-5.5.10-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-809349a09a

Comment 32 Fedora Update System 2019-03-18 17:47:49 UTC
puppet-5.5.10-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-12399acdc5

Comment 33 Fedora Update System 2019-03-27 03:27:17 UTC
puppet-5.5.10-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2019-03-27 15:00:03 UTC
puppet-5.5.10-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2019-03-29 19:17:05 UTC
puppet-5.5.10-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.