Bug 1654725 - openhpi build failed in f30
Summary: openhpi build failed in f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openhpi
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 14:28 UTC by Than Ngo
Modified: 2018-12-05 16:19 UTC (History)
10 users (show)

Fixed In Version: openhpi-3.8.0-7.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-05 16:19:57 UTC


Attachments (Terms of Use)

Description Than Ngo 2018-11-29 14:28:22 UTC
Description of problem:

some testcases failed due to the error: "missing Can not open libsnmp_bc plugin: /builddir/build/BUILD/openhpi-3.8.0/plugins/snmp_bc/t/.libs/libsnmp_bc.so.3: undefined symbol: saHpiSessionOpen"


How reproducible:


Steps to Reproduce:
1. rebuild openhpi in rawhide, you will see the failure of the build

Actual results:
build failure with the error:
missing Can not open libsnmp_bc plugin: /builddir/build/BUILD/openhpi-3.8.0/plugins/snmp_bc/t/.libs/libsnmp_bc.so.3: undefined symbol: saHpiSessionOpen"

Expected results:
it built fine like in f29

Comment 1 Nick Clifton 2018-11-29 16:17:42 UTC
Hi Ngo,

  You reported this problem as a problem with the binutils package, but
  I do not see how it is binutils related.  Is it possible that you have
  the wrong value set in the component field of the BZ ?

Cheers
  Nick

Comment 2 Than Ngo 2018-12-05 14:51:55 UTC
_ld_as_needed is enable in rawhide by default which causes this build failure in openhpi. It's a bug in openhpi.

Sorry for confusion. Reassigning it to correct component.

Comment 3 Than Ngo 2018-12-05 16:19:57 UTC
it's fixed in openhpi-3.8.0-7.fc30


Note You need to log in before you can comment on or make changes to this bug.