Bug 1654730 - shm leaks seen in gnome session after RHEL 7.6 update
Summary: shm leaks seen in gnome session after RHEL 7.6 update
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mesa
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Dave Airlie
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 14:46 UTC by Deepu K S
Modified: 2019-03-05 19:04 UTC (History)
2 users (show)

Fixed In Version: mesa-18.3.4-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-05 19:04:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Deepu K S 2018-11-29 14:46:20 UTC
Description of problem:
Since the 7.6 upgrade the gnome-shell process belonging to the logged in users uses lots of shared memory segments.
This gets increasing with time.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.6
mesa-dri-drivers-18.0.5-3.el7.x86_64
gnome-shell-3.28.3-6.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login to GNOME session on RHEL 7.6
2. Open firefox and use it for some time with some tabs opened.
3. Download some images.
4. Check the shared memory segments of gnome-shell and firefox.
# ipcs -mp

Actual results:
# ipcs -mp | awk '{ if ($2 == "test" && $3 == 1234) print $_ }' | wc -l
967

The gnome-shell process 1234 of the user above has 967 attached shared memory segments after using for sometime.

Expected results:
No shm leaks or un-controlled increase of shm segments.

Additional info:

Comment 10 Dave Airlie 2019-03-05 19:04:35 UTC
This is an internal bug and I've fixed it in development, so we can close it fo now.


Note You need to log in before you can comment on or make changes to this bug.